Bug 1416353 - Uncaught exception when attaching disk to a new VM
Summary: Uncaught exception when attaching disk to a new VM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.0.7
: ---
Assignee: Tal Nisan
QA Contact: Avihai
URL:
Whiteboard:
Depends On: 1394175
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 10:45 UTC by Tal Nisan
Modified: 2017-03-16 15:32 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1394175
Environment:
Last Closed: 2017-03-16 15:32:47 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0542 0 normal SHIPPED_LIVE Red Hat Virtualization Manager 4.0.7 2017-03-16 19:25:04 UTC

Description Tal Nisan 2017-01-25 10:45:35 UTC
+++ This bug was initially created as a clone of Bug #1394175 +++

Description of problem:
When I select a disk to attach to a VM and try to confirm the dialogue, nothing happens for the first time and suddenly wild uncaught exception appears.

Version-Release number of selected component (if applicable):
4.0.5-6

How reproducible:
always

Steps to Reproduce:
1. create new vm
2. select attach disk
3. select a disk and confirm the dialogue

Actual results:
uncaught exception

Expected results:
the VM has shiny old disk attached

Additional info:
2016-11-11 09:29:14,809 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-57) [] Permutation name: 3CA40F54CAD8AB6CAB935F5A4B10C074
2016-11-11 09:29:14,810 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-57) [] Uncaught exception: com.google.gwt.event.shared.UmbrellaExce
ption: Exception caught: Exception caught: (TypeError)
 __gwt$exception: <skipped>: a is null
        at java.lang.Throwable.fillInStackTrace(Throwable.java:114) [rt.jar:1.8.0_111]
        at java.lang.RuntimeException.RuntimeException(RuntimeException.java:32) [rt.jar:1.8.0_111]
        at com.google.web.bindery.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:70) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:25) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.HandlerManager.$fireEvent(HandlerManager.java:117) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.Widget.$fireEvent(Widget.java:127) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.Widget.fireEvent(Widget.java:127) [gwt-servlet.jar:]
        at com.google.gwt.event.dom.client.DomEvent.fireNativeEvent(DomEvent.java:110) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.Widget.$onBrowserEvent(Widget.java:163) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.CustomButton.onBrowserEvent(CustomButton.java:631) [gwt-servlet.jar:]
        at com.google.gwt.user.client.DOM.dispatchEvent(DOM.java:1648) [gwt-servlet.jar:]
        at com.google.gwt.user.client.impl.DOMImplStandard.dispatchEvent(DOMImplStandard.java:320) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.Impl.apply(Impl.java:296) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:335) [gwt-servlet.jar:]
        at Unknown.Sx/<(Unknown Source)
        at com.google.gwt.dom.client.DOMImplStandard.$dispatchEvent(DOMImplStandard.java:68) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.CustomButton.$onClick(CustomButton.java:822) [gwt-servlet.jar:]
        at org.ovirt.engine.ui.common.widget.dialog.AbstractDialogButton.onClick(AbstractDialogButton.java:45)
        at com.google.gwt.user.client.ui.CustomButton.onBrowserEvent(CustomButton.java:631) [gwt-servlet.jar:]
        at com.google.gwt.user.client.DOM.dispatchEvent(DOM.java:1648) [gwt-servlet.jar:]
        at com.google.gwt.user.client.DOM.dispatchEvent(DOM.java:1666) [gwt-servlet.jar:]
        at com.google.gwt.user.client.impl.DOMImplStandard.dispatchCapturedMouseEvent(DOMImplStandard.java:352) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.Impl.apply(Impl.java:296) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:335) [gwt-servlet.jar:]
        at Unknown.Sx/<(Unknown Source)
        at Unknown.anonymous(Unknown Source)
Caused by: com.google.gwt.event.shared.UmbrellaException: Exception caught: (TypeError)
 __gwt$exception: <skipped>: a is null
        at java.lang.Throwable.fillInStackTrace(Throwable.java:114) [rt.jar:1.8.0_111]
        at java.lang.RuntimeException.RuntimeException(RuntimeException.java:32) [rt.jar:1.8.0_111]
        at com.google.web.bindery.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:70) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:25) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.HandlerManager.$fireEvent(HandlerManager.java:117) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.Widget.$fireEvent(Widget.java:127) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.Widget.fireEvent(Widget.java:127) [gwt-servlet.jar:]
        at com.google.gwt.event.logical.shared.ValueChangeEvent.fire(ValueChangeEvent.java:40) [gwt-servlet.jar:]
        at org.ovirt.engine.ui.common.widget.uicommon.instanceimages.InstanceImageLineEditor$3.eventRaised(InstanceImageLineEditor.java:96)
        at org.ovirt.engine.ui.uicompat.Event.$raise(Event.java:114)
        at org.ovirt.engine.ui.uicommonweb.models.EntityModel.$setEntity(EntityModel.java:35)
        at org.ovirt.engine.ui.uicommonweb.models.EntityModel.setEntity(EntityModel.java:35)
        at org.ovirt.engine.ui.uicommonweb.models.vms.InstanceImageLineModel$2.onSave(InstanceImageLineModel.java:178)
        at org.ovirt.engine.ui.uicommonweb.models.vms.AbstractDiskModel.executeCommand(AbstractDiskModel.java:1046)
        at org.ovirt.engine.ui.uicommonweb.UICommand.$execute(UICommand.java:163)
        at org.ovirt.engine.ui.common.presenter.AbstractModelBoundPopupPresenterWidget$6.onClick(AbstractModelBoundPopupPresenterWidget.java:337)
        at com.google.gwt.event.dom.client.ClickEvent.dispatch(ClickEvent.java:55) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.GwtEvent.dispatch(GwtEvent.java:76) [gwt-servlet.jar:]
        at com.google.web.bindery.event.shared.SimpleEventBus.$doFire(SimpleEventBus.java:173) [gwt-servlet.jar:]
        ... 22 more
Caused by: com.google.gwt.core.client.JavaScriptException: (TypeError)
 __gwt$exception: <skipped>: a is null
        at org.ovirt.engine.ui.common.widget.AddRemoveRowWidget$AddRemoveRowPanel.$setButtonsEnabled(AddRemoveRowWidget.java:377)
        at org.ovirt.engine.ui.common.widget.AddRemoveRowWidget.$setButtonsEnabled(AddRemoveRowWidget.java:344)
        at org.ovirt.engine.ui.common.widget.AddRemoveRowWidget.toggleGhost(AddRemoveRowWidget.java:497)
        at org.ovirt.engine.ui.common.widget.AddRemoveRowWidget$3.onValueChange(AddRemoveRowWidget.java:232)
        at com.google.gwt.event.logical.shared.ValueChangeEvent.dispatch(ValueChangeEvent.java:127) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.GwtEvent.dispatch(GwtEvent.java:76) [gwt-servlet.jar:]
        at com.google.web.bindery.event.shared.SimpleEventBus.$doFire(SimpleEventBus.java:173) [gwt-servlet.jar:]
        ... 37 more

--- Additional comment from Petr Matyáš on 2016-11-11 12:34 IST ---



--- Additional comment from Yaniv Kaul on 2016-11-12 19:48:16 IST ---

Reminds me of bug 1364152 .

--- Additional comment from Tal Nisan on 2016-11-13 12:33:44 IST ---

Hi Petr,
I've tried to reproduce but could not (also tried the scenario from the screenshot, VM in up state and attaching a disk as an OS disk)
Can you please follow those steps and send me the UI log?

yum install ovirt-engine-webadmin-portal-debuginfo
Restart the engine service
Reproduce the issue and attach logs from var/log/ovirt-engine/ui.log

Thanks.

--- Additional comment from Petr Matyáš on 2016-11-14 18:11 IST ---

It should be the same as in Additional info.
In this case I used an old VM and tried to attach new disk through edit VM dialogue and the same error appeared.

--- Additional comment from Allon Mureinik on 2016-11-14 23:26:15 IST ---

Tentatively targetting for 4.0.6 until we understand what's going on here.

--- Additional comment from Tal Nisan on 2016-12-19 16:33:12 IST ---

Petr, can it be that the data center is down at the time of attachment?

--- Additional comment from Dmitry Glushenok on 2016-12-20 11:50:42 IST ---

Was experiencing similar problem with ovirt-engine 4.0.5.5 (logs below). The problem gone after upgrading to 4.0.6.3 pre-release.


2016-12-20 11:47:51,452 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-16) [] Permutation name: 36FFE9E683BD2C616FFB067DABA3A81E
2016-12-20 11:47:51,456 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-16) [] Uncaught exception: com.google.gwt.event.shared.UmbrellaException: Exception caught: Exception caught: (TypeError) 
 __gwt$exception: <skipped>: Cannot read property 'b' of null
	at java.lang.Throwable.fillInStackTrace(Throwable.java:114) [rt.jar:1.8.0_111]
	at java.lang.RuntimeException.RuntimeException(RuntimeException.java:32) [rt.jar:1.8.0_111]
	at com.google.web.bindery.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:70) [gwt-servlet.jar:]
	at com.google.gwt.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:25) [gwt-servlet.jar:]
	at com.google.gwt.event.shared.HandlerManager.$fireEvent(HandlerManager.java:117) [gwt-servlet.jar:]
	at com.google.gwt.user.client.ui.Widget.$fireEvent(Widget.java:127) [gwt-servlet.jar:]
	at com.google.gwt.user.client.ui.Widget.fireEvent(Widget.java:127) [gwt-servlet.jar:]
	at com.google.gwt.event.dom.client.DomEvent.fireNativeEvent(DomEvent.java:110) [gwt-servlet.jar:]
	at com.google.gwt.user.client.ui.Widget.$onBrowserEvent(Widget.java:163) [gwt-servlet.jar:]
	at com.google.gwt.user.client.ui.CustomButton.onBrowserEvent(CustomButton.java:631) [gwt-servlet.jar:]
	at com.google.gwt.user.client.DOM.dispatchEvent(DOM.java:1648) [gwt-servlet.jar:]
	at com.google.gwt.user.client.impl.DOMImplStandard.dispatchEvent(DOMImplStandard.java:320) [gwt-servlet.jar:]
	at com.google.gwt.core.client.impl.Impl.apply(Impl.java:296) [gwt-servlet.jar:]
	at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:335) [gwt-servlet.jar:]
	at Unknown.eval(webadmin-0.js@54)
	at com.google.gwt.dom.client.DOMImplStandard.$dispatchEvent(DOMImplStandard.java:68) [gwt-servlet.jar:]
	at com.google.gwt.user.client.ui.CustomButton.$onClick(CustomButton.java:822) [gwt-servlet.jar:]
	at org.ovirt.engine.ui.common.widget.dialog.AbstractDialogButton.onClick(AbstractDialogButton.java:45)
	at com.google.gwt.user.client.ui.CustomButton.onBrowserEvent(CustomButton.java:631) [gwt-servlet.jar:]
	at com.google.gwt.user.client.DOM.dispatchEvent(DOM.java:1648) [gwt-servlet.jar:]
	at com.google.gwt.user.client.DOM.dispatchEvent(DOM.java:1666) [gwt-servlet.jar:]
	at com.google.gwt.user.client.impl.DOMImplStandard.dispatchCapturedMouseEvent(DOMImplStandard.java:352) [gwt-servlet.jar:]
	at com.google.gwt.core.client.impl.Impl.apply(Impl.java:296) [gwt-servlet.jar:]
	at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:335) [gwt-servlet.jar:]
	at Unknown.eval(webadmin-0.js@54)
Caused by: com.google.gwt.event.shared.UmbrellaException: Exception caught: (TypeError) 
 __gwt$exception: <skipped>: Cannot read property 'b' of null
	at java.lang.Throwable.fillInStackTrace(Throwable.java:114) [rt.jar:1.8.0_111]
	at java.lang.RuntimeException.RuntimeException(RuntimeException.java:32) [rt.jar:1.8.0_111]
	at com.google.web.bindery.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:70) [gwt-servlet.jar:]
	at com.google.gwt.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:25) [gwt-servlet.jar:]
	at com.google.gwt.event.shared.HandlerManager.$fireEvent(HandlerManager.java:117) [gwt-servlet.jar:]
	at com.google.gwt.user.client.ui.Widget.$fireEvent(Widget.java:127) [gwt-servlet.jar:]
	at com.google.gwt.user.client.ui.Widget.fireEvent(Widget.java:127) [gwt-servlet.jar:]
	at com.google.gwt.event.logical.shared.ValueChangeEvent.fire(ValueChangeEvent.java:40) [gwt-servlet.jar:]
	at org.ovirt.engine.ui.common.widget.uicommon.instanceimages.InstanceImageLineEditor$3.eventRaised(InstanceImageLineEditor.java:96)
	at org.ovirt.engine.ui.uicompat.Event.$raise(Event.java:114)
	at org.ovirt.engine.ui.uicommonweb.models.EntityModel.$setEntity(EntityModel.java:35)
	at org.ovirt.engine.ui.uicommonweb.models.EntityModel.setEntity(EntityModel.java:35)
	at org.ovirt.engine.ui.uicommonweb.models.vms.InstanceImageLineModel$2.onSave(InstanceImageLineModel.java:178)
	at org.ovirt.engine.ui.uicommonweb.models.vms.AbstractDiskModel.executeCommand(AbstractDiskModel.java:1046)
	at org.ovirt.engine.ui.uicommonweb.UICommand.$execute(UICommand.java:163)
	at org.ovirt.engine.ui.common.presenter.AbstractModelBoundPopupPresenterWidget$6.onClick(AbstractModelBoundPopupPresenterWidget.java:337)
	at com.google.gwt.event.dom.client.ClickEvent.dispatch(ClickEvent.java:55) [gwt-servlet.jar:]
	at com.google.gwt.event.shared.GwtEvent.dispatch(GwtEvent.java:76) [gwt-servlet.jar:]
	at com.google.web.bindery.event.shared.SimpleEventBus.$doFire(SimpleEventBus.java:173) [gwt-servlet.jar:]
	... 21 more
Caused by: com.google.gwt.core.client.JavaScriptException: (TypeError) 
 __gwt$exception: <skipped>: Cannot read property 'b' of null
	at org.ovirt.engine.ui.common.widget.AddRemoveRowWidget$AddRemoveRowPanel.$setButtonsEnabled(AddRemoveRowWidget.java:377)
	at org.ovirt.engine.ui.common.widget.AddRemoveRowWidget.$setButtonsEnabled(AddRemoveRowWidget.java:344)
	at org.ovirt.engine.ui.common.widget.AddRemoveRowWidget.toggleGhost(AddRemoveRowWidget.java:497)
	at org.ovirt.engine.ui.common.widget.AddRemoveRowWidget$3.onValueChange(AddRemoveRowWidget.java:232)
	at com.google.gwt.event.logical.shared.ValueChangeEvent.dispatch(ValueChangeEvent.java:127) [gwt-servlet.jar:]
	at com.google.gwt.event.shared.GwtEvent.dispatch(GwtEvent.java:76) [gwt-servlet.jar:]
	at com.google.web.bindery.event.shared.SimpleEventBus.$doFire(SimpleEventBus.java:173) [gwt-servlet.jar:]
	... 36 more

--- Additional comment from Tal Nisan on 2016-12-20 11:53:42 IST ---

Dmitry, did this happen when all data centers were down?

--- Additional comment from Dmitry Glushenok on 2016-12-20 11:58:06 IST ---

No, the single datacenter was up. It is fresh sandbox install. There is one datacenter, one cluster and one host.
One unusual thing is I was attaching RBD images with Cinder provider (didn't tried regular disk images).

--- Additional comment from Tal Nisan on 2016-12-25 14:27:07 IST ---

OK, this issue is fixed in 4.0.6 so an upgrade will fix it.
As a work around you can create the VM first and then attach the disk from the disks sub tab.
Marking as MODIFIED so it will be tested on 4.0.7 to make sure although I've tried myself and could not reproduce.

--- Additional comment from Sandro Bonazzola on 2017-01-25 09:56:29 IST ---

4.0.6 has been the last oVirt 4.0 release, please re-target this bug.

Comment 2 Avihai 2017-01-26 15:01:56 UTC
verified.

Engine :
ovirt-engine-4.0.7-0.1.el7ev.noarch

Vdsm:
4.18.22-1

Comment 4 errata-xmlrpc 2017-03-16 15:32:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0542.html


Note You need to log in before you can comment on or make changes to this bug.