Bug 1416363 - Clicking on Group or Role name link/icon in the user's details page does nothing
Summary: Clicking on Group or Role name link/icon in the user's details page does nothing
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: GA
: 5.9.0
Assignee: Brian McLaughlin
QA Contact: Matouš Mojžíš
URL:
Whiteboard: ui
: 1428311 (view as bug list)
Depends On:
Blocks: 1443245 1443246
TreeView+ depends on / blocked
 
Reported: 2017-01-25 11:21 UTC by Ramesh A
Modified: 2018-03-06 14:35 UTC (History)
7 users (show)

Fixed In Version: 5.9.0.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1443245 1443246 (view as bug list)
Environment:
Last Closed: 2018-03-06 14:35:38 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:
rananda: automate_bug-


Attachments (Terms of Use)

Description Ramesh A 2017-01-25 11:21:18 UTC
Description of problem:
Clicking on Group or Role link in the user's details page does nothing.  **This happens in fresh install and until the logged in user does not click on any Group/Role**

Version-Release number of selected component (if applicable):
5.7.1.0.20170124142149_8a5f4d5

How reproducible:
Very

Steps to Reproduce:
1. Install a **FRESH APPLIANCE**
2. Navigate to Configuration ==> Access Control ==> Users
3. Click on any user
4. In the User details page, click on Group/Role name link or the icon next to Group/Role name

Actual results:
Nothing happens, it stays in the same page.

However, if we manually click on the Group/Role link in the left accordion and load any of the Group/Role details page, and later navigate to the user details page and try clicking on the Group/Role link/icon in the user details section, the page navigates to the respective Group/Role details page.


Expected results:
Should open up Group/Role details page

Additional info:

Comment 2 Ramesh A 2017-01-25 11:32:39 UTC
Same behavior is noticed in the below sections too.
1. Navigate to any Group, click on the User name link icon/Role name link or icon next to it
2. Navigate to any Role Details page and click on the Group name link or icon next to it

As said, this is till the respective pages are opened, once they accessed manually this behavior is not noticed.

Comment 4 Brian McLaughlin 2017-03-10 16:19:35 UTC
*** Bug 1428311 has been marked as a duplicate of this bug. ***

Comment 6 CFME Bot 2017-04-18 18:03:32 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:
https://github.com/ManageIQ/manageiq-ui-classic/commit/85552f54f98377a2232267828246bc5c29758393

commit 85552f54f98377a2232267828246bc5c29758393
Author:     Brian McLaughlin <bmclaugh@redhat.com>
AuthorDate: Fri Mar 10 11:20:55 2017 -0500
Commit:     Brian McLaughlin <bmclaugh@redhat.com>
CommitDate: Thu Mar 23 14:39:53 2017 -0400

    Fix Group/Role name links on User Details page
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1416363

 app/assets/javascripts/miq_tree.js          | 26 ++++++++++++++++++++++++++
 app/views/ops/_rbac_group_details.html.haml |  2 +-
 app/views/ops/_rbac_role_details.html.haml  |  2 +-
 app/views/ops/_rbac_user_details.html.haml  |  4 ++--
 4 files changed, 30 insertions(+), 4 deletions(-)

Comment 7 CFME Bot 2017-04-18 18:03:38 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:
https://github.com/ManageIQ/manageiq-ui-classic/commit/52a566b862ca326602e935b695de0c6b643780e6

commit 52a566b862ca326602e935b695de0c6b643780e6
Author:     Brian McLaughlin <bmclaugh@redhat.com>
AuthorDate: Fri Mar 10 13:21:14 2017 -0500
Commit:     Brian McLaughlin <bmclaugh@redhat.com>
CommitDate: Thu Mar 23 14:39:53 2017 -0400

    Fix style issue
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1416363

 app/assets/javascripts/miq_tree.js | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comment 8 CFME Bot 2017-04-18 18:03:44 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:
https://github.com/ManageIQ/manageiq-ui-classic/commit/17d746515efeaf6a8a096af9920c7f80145de25e

commit 17d746515efeaf6a8a096af9920c7f80145de25e
Author:     Brian McLaughlin <bmclaugh@redhat.com>
AuthorDate: Thu Mar 23 14:39:31 2017 -0400
Commit:     Brian McLaughlin <bmclaugh@redhat.com>
CommitDate: Thu Mar 23 14:39:53 2017 -0400

    Refactored js function
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1416363

 app/assets/javascripts/miq_tree.js | 19 +++----------------
 1 file changed, 3 insertions(+), 16 deletions(-)

Comment 9 CFME Bot 2017-04-18 18:03:51 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:
https://github.com/ManageIQ/manageiq-ui-classic/commit/d0824f97b56c2c34695e7d02bd481afe1e9f6bae

commit d0824f97b56c2c34695e7d02bd481afe1e9f6bae
Author:     Brian McLaughlin <bmclaugh@redhat.com>
AuthorDate: Thu Apr 6 10:08:18 2017 -0400
Commit:     Brian McLaughlin <bmclaugh@redhat.com>
CommitDate: Thu Apr 6 10:08:18 2017 -0400

    Add missing spinner
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1416363

 app/assets/javascripts/miq_tree.js | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comment 12 Matouš Mojžíš 2017-11-22 09:54:45 UTC
Verified in 5.9.0.9. It redirects me to Group or Role after clicking on its name in user's details.


Note You need to log in before you can comment on or make changes to this bug.