Bug 1416375 - OVA VMs exported from VMWare won't be imported to oVirt
Summary: OVA VMs exported from VMWare won't be imported to oVirt
Keywords:
Status: CLOSED DUPLICATE of bug 1367839
Alias: None
Product: vdsm
Classification: oVirt
Component: Core
Version: ---
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Dan Kenigsberg
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 11:36 UTC by Prado
Modified: 2017-02-01 11:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-01 11:59:29 UTC
oVirt Team: Virt


Attachments (Terms of Use)
Engine log with the fail occurrence. (21.30 KB, text/plain)
2017-01-25 11:36 UTC, Prado
no flags Details
vdsm.log from engine (171.82 KB, text/plain)
2017-01-31 12:48 UTC, Prado
no flags Details
vdsm.log from the node which was importing the VM. (243.03 KB, text/plain)
2017-01-31 12:52 UTC, Prado
no flags Details

Description Prado 2017-01-25 11:36:45 UTC
Created attachment 1244222 [details]
Engine log with the fail occurrence.

oVirt has an interface at the "Virtual Machines" tab that permits the user to import a OVA VMWare VM.

A dummy VM was generated for VMWare from a CentOS 6 64bits template.
In order to import this VM from VMWare vSphere to oVirt, the events tab says: "Failed to import Vm TestOVA to Data Center node5, Cluster node5"


The logs at ovirt-engine.log says:
"Conversion of VM from exteral enironment failed: Job u'6aa362ee-09ca-4e2f-85c3-3a1c6d6ef4e0' process failed exit-code: 1, stderr: virt-v2v: error: internal error: Not_found exception was thrown"


My workaround for this error was execute a conversion of the OVA file to a raw VM using virt-v2v and then export it to my oVirt Export Volume:
# export LIBGUESTFS_BACKEND=direct #(https://access.redhat.com/solutions/2110391)
# virt-v2v -v -x -i ova VM_NAME.ova -o local -of raw -os $TMPDIR
# virt-v2v -v -x -i libvirtxml VM_NAME.xml -o rhev -os nas.ped.datacom.ind.br:/nas/vol-export --network rhevm

And then edit the new OVF file inside the vol-export volume in order to insert a MACAddress value (https://access.redhat.com/solutions/2695501).


Software versions:
- oVirt Engine Version: 4.0.5.5-1.el7.centos
- VMWare vSphere 5.5 release 3248547

Steps to Reproduce:
1. Generate a dummy VM from CentOS 6 64bits template at VMWare vSphere.
2. Export the VM as OVA file.
3. Try to import the VM to oVirt over the "Import" interface at the "Virtual Machines" tab.

Actual results:
Events tab says: "Failed to import Vm TestOVA to Data Center node5, Cluster node5"

Expected results:
VM TestOVA Successful imported.

Comment 1 Tomas Jelinek 2017-01-31 08:40:40 UTC
Please provide also vdsm logs from the proxy host.

Comment 2 Prado 2017-01-31 12:48:54 UTC
Created attachment 1246223 [details]
vdsm.log from engine

As requested.

Comment 3 Prado 2017-01-31 12:52:55 UTC
Created attachment 1246224 [details]
vdsm.log from the node which was importing the VM.

Comment 4 Tomáš Golembiovský 2017-02-01 11:59:29 UTC
This is fixed in VDSM 4.18.2.

*** This bug has been marked as a duplicate of bug 1367839 ***


Note You need to log in before you can comment on or make changes to this bug.