Bug 1416406 - Guest agent from 4.0 can't be upgraded to GA from 4.1
Summary: Guest agent from 4.0 can't be upgraded to GA from 4.1
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-guest-agent
Classification: oVirt
Component: Packaging
Version: 1.0.13
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.1.1
: ---
Assignee: Vinzenz Feenstra [evilissimo]
QA Contact: Petr Matyáš
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 12:41 UTC by Petr Matyáš
Modified: 2017-04-21 09:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-21 09:35:44 UTC
oVirt Team: Virt
rule-engine: ovirt-4.1+
rule-engine: planning_ack+
tjelinek: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)

Description Petr Matyáš 2017-01-25 12:41:00 UTC
Description of problem:
Updating guest agent from 4.0 (rhevm-guest-agent) to 4.1 (ovirt-guest-agent) is not possible because of yum conflicts.

Version-Release number of selected component (if applicable):
4.1.0-9

How reproducible:
always

Steps to Reproduce:
1. add repos for 4.0 GA and install rhevm-guest-agent
2. add repos for 4.1 GA and update rhevm-guest-agent
3.

Actual results:
transaction error

Expected results:
updated package rhevm-guest-agent so it is overwritten to ovirt-guest-agent

Additional info:
Transaction check error:
  file /etc/ovirt-guest-agent.conf from install of ovirt-guest-agent-common-1.0.13-2.el7ev.noarch conflicts with file from package rhevm-guest-agent-common-1.0.12-3.el7ev.noarch
  file /etc/udev/rules.d/55-ovirt-guest-agent.rules from install of ovirt-guest-agent-common-1.0.13-2.el7ev.noarch conflicts with file from package rhevm-guest-agent-common-1.0.12-3.el7ev.noarch
  file /usr/share/ovirt-guest-agent/CredServer.pyc from install of ovirt-guest-agent-common-1.0.13-2.el7ev.noarch conflicts with file from package rhevm-guest-agent-common-1.0.12-3.el7ev.noarch
  file /usr/share/ovirt-guest-agent/CredServer.pyo from install of ovirt-guest-agent-common-1.0.13-2.el7ev.noarch conflicts with file from package rhevm-guest-agent-common-1.0.12-3.el7ev.noarch
  file /usr/share/ovirt-guest-agent/GuestAgentLinux2.pyc from install of ovirt-guest-agent-common-1.0.13-2.el7ev.noarch conflicts with file from package rhevm-guest-agent-common-1.0.12-3.el7ev.noarch
  file /usr/share/ovirt-guest-agent/GuestAgentLinux2.pyo from install of ovirt-guest-agent-common-1.0.13-2.el7ev.noarch conflicts with file from package rhevm-guest-agent-common-1.0.12-3.el7ev.noarch
  file /usr/share/ovirt-guest-agent/OVirtAgentLogic.py from install of ovirt-guest-agent-common-1.0.13-2.el7ev.noarch conflicts with file from package rhevm-guest-agent-common-1.0.12-3.el7ev.noarch
  file /usr/share/ovirt-guest-agent/OVirtAgentLogic.pyc from install of ovirt-guest-agent-common-1.0.13-2.el7ev.noarch conflicts with file from package rhevm-guest-agent-common-1.0.12-3.el7ev.noarch
  file /usr/share/ovirt-guest-agent/OVirtAgentLogic.pyo from install of ovirt-guest-agent-common-1.0.13-2.el7ev.noarch conflicts with file from package rhevm-guest-agent-common-1.0.12-3.el7ev.noarch
  file /usr/share/ovirt-guest-agent/VirtIoChannel.py from install of ovirt-guest-agent-common-1.0.13-2.el7ev.noarch conflicts with file from package rhevm-guest-agent-common-1.0.12-3.el7ev.noarch
  file /usr/share/ovirt-guest-agent/VirtIoChannel.pyc from install of ovirt-guest-agent-common-1.0.13-2.el7ev.noarch conflicts with file from package rhevm-guest-agent-common-1.0.12-3.el7ev.noarch
  file /usr/share/ovirt-guest-agent/VirtIoChannel.pyo from install of ovirt-guest-agent-common-1.0.13-2.el7ev.noarch conflicts with file from package rhevm-guest-agent-common-1.0.12-3.el7ev.noarch
  file /usr/share/ovirt-guest-agent/default.conf from install of ovirt-guest-agent-common-1.0.13-2.el7ev.noarch conflicts with file from package rhevm-guest-agent-common-1.0.12-3.el7ev.noarch
  file /usr/share/ovirt-guest-agent/hooks.pyc from install of ovirt-guest-agent-common-1.0.13-2.el7ev.noarch conflicts with file from package rhevm-guest-agent-common-1.0.12-3.el7ev.noarch
  file /usr/share/ovirt-guest-agent/hooks.pyo from install of ovirt-guest-agent-common-1.0.13-2.el7ev.noarch conflicts with file from package rhevm-guest-agent-common-1.0.12-3.el7ev.noarch
  file /usr/share/ovirt-guest-agent/ovirt-guest-agent.pyc from install of ovirt-guest-agent-common-1.0.13-2.el7ev.noarch conflicts with file from package rhevm-guest-agent-common-1.0.12-3.el7ev.noarch
  file /usr/share/ovirt-guest-agent/ovirt-guest-agent.pyo from install of ovirt-guest-agent-common-1.0.13-2.el7ev.noarch conflicts with file from package rhevm-guest-agent-common-1.0.12-3.el7ev.noarch
  file /usr/share/ovirt-guest-agent/timezone.pyc from install of ovirt-guest-agent-common-1.0.13-2.el7ev.noarch conflicts with file from package rhevm-guest-agent-common-1.0.12-3.el7ev.noarch
  file /usr/share/ovirt-guest-agent/timezone.pyo from install of ovirt-guest-agent-common-1.0.13-2.el7ev.noarch conflicts with file from package rhevm-guest-agent-common-1.0.12-3.el7ev.noarch

Comment 2 Petr Matyáš 2017-02-01 12:28:44 UTC
Verified on update from 4.0.7-1 to 4.1.0-11


Note You need to log in before you can comment on or make changes to this bug.