Bug 1416416 - Improve output of "gluster volume status detail"
Summary: Improve output of "gluster volume status detail"
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: 3.10
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact:
URL:
Whiteboard:
Depends On: 1411334
Blocks: 1415131 1415132 1415133
TreeView+ depends on / blocked
 
Reported: 2017-01-25 13:06 UTC by Kaleb KEITHLEY
Modified: 2017-03-06 17:44 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1411334
Environment:
Last Closed: 2017-03-06 17:44:28 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kaleb KEITHLEY 2017-01-25 13:06:17 UTC
+++ This bug was initially created as a clone of Bug #1411334 +++

Description of problem:

Currently "gluster volume status detail" only gives all available information for linux hosts. Additionally, if the command is executed from a FreeBSD node, some brick information is hidden, even if it comes from a linux brick.


Version-Release number of selected component (if applicable): mainline


How reproducible:

Always

Steps to Reproduce:
1. Create a distributed volume with one brick on CentOS and another one on FreeBSD
2. Run gluster volume status <volname> detail on CentOS
3. Run gluster volume status <volname> detail on FreeBSD

Actual results:

On CentOS, some information from the brick hosted by FreeBSD appears as "N/A". On FreeBSD some information is missing, even from the CentOS brick.

Expected results:

Both commands should return the same output and all available info should be filled instead of writing "N/A".

Additional info:

--- Additional comment from Worker Ant on 2017-01-10 05:31:07 EST ---

REVIEW: http://review.gluster.org/16371 (cli: keep 'gluster volume status detail' consistent) posted (#1) for review on master by Xavier Hernandez (xhernandez@datalab.es)

--- Additional comment from Worker Ant on 2017-01-10 05:39:10 EST ---

REVIEW: http://review.gluster.org/16371 (cli: keep 'gluster volume status detail' consistent) posted (#2) for review on master by Xavier Hernandez (xhernandez@datalab.es)

--- Additional comment from Worker Ant on 2017-01-19 18:52:30 EST ---

COMMIT: http://review.gluster.org/16371 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 7b5b7111c9d9a2a65e4f4d0abf832a88e021c576
Author: Xavier Hernandez <xhernandez@datalab.es>
Date:   Tue Jan 10 11:21:06 2017 +0100

    cli: keep 'gluster volume status detail' consistent
    
    The output of the command 'gluster volume status <volname> detail' is
    not consistent between operating systems. On linux hosts it shows the
    file system type, the device name, mount options and inode size of each
    brick. However the same command executed on a FreeBSD host doesn't show
    all this information, even for bricks stored on a linux.
    
    Additionally, for hosts other than linux, this information is shown as
    'N/A' many times. This has been fixed to show as much information as it
    can be retrieved from the operating system.
    
    The file contrib/mount/mntent.c has been mostly rewriten because it
    contained many errors that caused mount information to not be retrieved
    on some operating systems.
    
    Change-Id: Icb6e19e8af6ec82255e7792ad71914ef679fc316
    BUG: 1411334
    Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
    Reviewed-on: http://review.gluster.org/16371
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>

Comment 1 Worker Ant 2017-01-25 13:14:28 UTC
REVIEW: https://review.gluster.org/16469 (i: keep 'gluster volume status detail' consistent) posted (#1) for review on release-3.10 by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 2 Worker Ant 2017-01-25 13:15:50 UTC
REVIEW: https://review.gluster.org/16469 (cli: keep 'gluster volume status detail' consistent) posted (#2) for review on release-3.10 by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 3 Worker Ant 2017-01-26 14:11:20 UTC
COMMIT: https://review.gluster.org/16469 committed in release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 107b22c96a354c43f6557bd1e307fa1dff5b5fb5
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Wed Jan 25 08:10:17 2017 -0500

    cli: keep 'gluster volume status detail' consistent
    
    The output of the command 'gluster volume status <volname> detail' is
    not consistent between operating systems. On linux hosts it shows the
    file system type, the device name, mount options and inode size of each
    brick. However the same command executed on a FreeBSD host doesn't show
    all this information, even for bricks stored on a linux.
    
    Additionally, for hosts other than linux, this information is shown as
    'N/A' many times. This has been fixed to show as much information as it
    can be retrieved from the operating system.
    
    The file contrib/mount/mntent.c has been mostly rewriten because it
    contained many errors that caused mount information to not be retrieved
    on some operating systems.
    
    Master BZ 1411334
    Master review https://review.gluster.org/#/c/16371/
    
    Change-Id: Icb6e19e8af6ec82255e7792ad71914ef679fc316
    BUG: 1416416
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
    Reviewed-on: https://review.gluster.org/16469
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>

Comment 4 Shyamsundar 2017-03-06 17:44:28 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.