Bug 1416421 - OVS DPDK bonds fail to configure during provisioning
Summary: OVS DPDK bonds fail to configure during provisioning
Keywords:
Status: CLOSED DUPLICATE of bug 1396605
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: os-net-config
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
: 10.0 (Newton)
Assignee: Sanjay Upadhyay
QA Contact: Yariv
URL:
Whiteboard:
Depends On: 1396605
Blocks: 1335596 1406834
TreeView+ depends on / blocked
 
Reported: 2017-01-25 13:13 UTC by Sanjay Upadhyay
Modified: 2017-02-15 06:54 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
While creating the DPDK bond, `if-up` of the bond interface will activate the member iterfaces by itself. Individual members should not be able to call for `if-up`. As a result, the deployment fails with bonding in the OVS-DPDK use case. As a workaround, you need to comment out the interfaces in the `impl_ifcfg.py` file as follows: # if base_opt.primary_interface_name: # primary_name = base_opt.primary_interface_name # self.bond_primary_ifaces[base_opt.name] = primary_name
Clone Of: 1396605
Environment:
Last Closed: 2017-01-25 15:00:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1643026 None None None 2017-01-25 13:13:38 UTC
OpenStack gerrit 417805 None None None 2017-01-25 13:13:38 UTC

Comment 1 Sanjay Upadhyay 2017-01-25 15:00:24 UTC

*** This bug has been marked as a duplicate of bug 1396605 ***


Note You need to log in before you can comment on or make changes to this bug.