Bug 1416422 - Impress locks up with 99% CPU usage under Wayland
Summary: Impress locks up with 99% CPU usage under Wayland
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 13:14 UTC by Christian Fredrik Kalager Schaller
Modified: 2017-07-06 12:51 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-05 12:45:29 UTC
Type: Bug


Attachments (Terms of Use)

Description Christian Fredrik Kalager Schaller 2017-01-25 13:14:05 UTC
Trying to write my slides using Impress under Wayland, but the GPU usage keeps going up to 99% and Impress becomes unresponsive.

Comment 1 David Tardon 2017-01-26 09:34:05 UTC
We don't have any similar bug report, which means this is somehow related to your system or usage pattern... Are there concrete steps to get the hangout? Does it happen in a new presentation, or only with a template? Or when inserting an image? Does it happen in normal or outline mode?

If it is not specific to some usage pattern, it might help to get a backtrace: run

dnf debuginfo-install libreoffice-impress

as root to install debuginfo, then start impress, make it hang and run

pstack `pidof soffice.bin` > backtrace

and attach the file 'backtrace' here.

As a workaround, you can use the old gtk2 backend, which doesn't use Wayland. Ensure libreoffice-gtk2 is installed, then start libreoffice from terminal as

SAL_USE_VCLPLUGIN=gtk libreoffice

Comment 2 Caolan McNamara 2017-01-26 11:59:40 UTC
could log in under X too to see if its related to wayland and we're innocent or if it persists to rule that in or out

Comment 3 Christian Fredrik Kalager Schaller 2017-07-05 12:45:29 UTC
Closing this old bug as I can't reproduce anymore

Comment 4 Caolan McNamara 2017-07-06 12:51:15 UTC
I bet this was the bug in glib which triggered 100% cpu usage.


Note You need to log in before you can comment on or make changes to this bug.