Bug 1416423 - Previous signatures with images not sent properly
Summary: Previous signatures with images not sent properly
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milan Crha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 13:19 UTC by Louis van Dyk
Modified: 2017-01-26 12:49 UTC (History)
4 users (show)

Fixed In Version: evolution-3.22.5
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-26 12:49:50 UTC
Type: Bug


Attachments (Terms of Use)

Description Louis van Dyk 2017-01-25 13:19:51 UTC
Description of problem:
I upgraded from Fedora 24 to Fedora 25 over the weekend.  Previously, sending an email from Evolution where the signature (developed in April 2013) contained lines like:

<CODE>

<TR>
<TD WIDTH="17">
<IMG SRC="file:///home/louis/.local/share/evolution/signatures/red-dot.gif" WIDTH="7" HEIGHT="11" ALIGN="bottom" BORDER="0">
</TD>
<TD NOWRAP>
<B>Louis van Dyk</B>
</TD>
</TR>

</CODE>

would show the line with the image and the text with my name following that.

Since the upgrade users of Outlook report getting an error when opening one of my emails:
Contacting:
\\home\louis\.local\share\evolution\signatures\red-dot.gif

If I send an email to my GMAIL account, the red dot is not there - where it used to show before.

So I recreated my signature with the current Evolution, then I noticed that now the new file has the image MIME-base64 embedded in the signature file.  A brilliant approach!

However, for those of us who are not aware of it, the signature is broken and causes chaos amongst the Outlook crowd.  

I don't know what to suggest here, other than maybe a pop-up warning telling the email author that his signature no longer conforms and needs to be converted, possibly even doing it for him?



Version-Release number of selected component (if applicable):
evolution-3.22.4-2.fc25.x86_64
evolution-data-server-3.22.4-1.fc25.x86_64
evolution-ews-3.22.4-1.fc25.x86_64
evolution-help-3.22.4-2.fc25.noarch



How reproducible:
Every time when using the old email signature.



Steps to Reproduce:
1. Using an old signature referring to a physical image file on the filesystem, write a message including it.
2. Outlook users get an error looking for the file in the file path mentioned in the signature, and GMAIL users just don't see the image.
3. Recreate the signature file in Evolution, and the new file contains the embedded image and works.


Actual results:
As above


Expected results:
Some warning to the unsuspecting Evolution message author, or guidance in converting his signatures would make it more "Linux Desktop User Friendly".


Additional info:

Comment 1 Milan Crha 2017-01-25 14:25:10 UTC
Thanks for a bug report. I agree, it's a shame. The right approach would be to attach such images transparently, thus no change is required from the user.

Comment 2 Milan Crha 2017-01-26 12:49:50 UTC
Created commit 2c037de in evo master (3.23.90+) [1]
Created commit d8090af in evo gnome-3-22 (3.22.5+) [2]

[1] https://git.gnome.org/browse/evolution/commit/?id=2c037de
[2] https://git.gnome.org/browse/evolution/commit/?id=d8090af


Note You need to log in before you can comment on or make changes to this bug.