Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1416448 - Cannot create virtual machine disk from UI
Summary: Cannot create virtual machine disk from UI
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: General
Version: 4.1.0.2
Hardware: x86_64
OS: All
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Shahar Havivi
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 14:17 UTC by Egor
Modified: 2017-02-07 07:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-07 07:11:47 UTC
oVirt Team: Virt


Attachments (Terms of Use)
The page where an exception is seen (93.39 KB, image/png)
2017-01-25 14:17 UTC, Egor
no flags Details
Logs with exception (5.61 MB, application/zip)
2017-01-25 14:22 UTC, Egor
no flags Details
New error message box (6.38 KB, image/png)
2017-01-27 11:43 UTC, Egor
no flags Details
Internal Engine Error logs (5.69 MB, application/zip)
2017-01-27 11:49 UTC, Egor
no flags Details
Python script log (3.64 KB, text/plain)
2017-01-27 13:54 UTC, Egor
no flags Details
Requested data for bug (6.22 MB, application/zip)
2017-02-01 15:46 UTC, Egor
no flags Details

Description Egor 2017-01-25 14:17:11 UTC
Created attachment 1244271 [details]
The page where an exception is seen

Description of problem:
I try to create virtual machine and Disk for it from ovirt web interface. I set up Disk parameters and receive error.

Steps to Reproduce:
1. Start creating new virtual machine
2. In the message box with parameters for new virtual machine, press button "+" and "Create" to add new Disk.
3. Fill in all the necessary parameters of the Disk in the new message box as seen in the screenshot and press "Ok".

Actual results:
I see an exception in the web interface.

Expected results:
The Disk is created successfully.


Additional info:
There was a virtual machine with the same name before and there was a Disk with that same name.

Comment 1 Egor 2017-01-25 14:22:25 UTC
Created attachment 1244272 [details]
Logs with exception

Comment 2 Greg Sheremeta 2017-01-26 13:36:40 UTC
Thanks for the report.

Can you please install the GWT symbol maps, reproduce again, and attach the new ui.log?

yum install ovirt-engine-webadmin-portal-debuginfo ovirt-engine-userportal-debuginfo

ui.log will then have a deobfuscated stack trace that can point us in the right direction.

...

Not sure if it's related, but in engine.log, I see:

2017-01-20 19:51:42,479 ERROR [org.ovirt.engine.api.restapi.resource.validation.IOExceptionMapper] (default task-62) [] IO exception while processing "POST" request for path "/disks"
2017-01-20 19:51:42,479 ERROR [org.ovirt.engine.api.restapi.resource.validation.IOExceptionMapper] (default task-62) [] Exception: java.io.IOException: javax.xml.bind.UnmarshalException: unexpected element (uri:"", local:"storage_domains"). Expected elements are <{}total>,<{}size>,<{}active>,<{}actions>,<{}storage_domain>
	at org.ovirt.engine.api.restapi.xml.JAXBProvider.readFrom(JAXBProvider.java:199) [restapi-jaxrs.jar:]
	at org.ovirt.engine.api.restapi.xml.JAXBProvider.readFrom(JAXBProvider.java:161) [restapi-jaxrs.jar:]
	at org.jboss.resteasy.core.interception.AbstractReaderInterceptorContext.readFrom(AbstractReaderInterceptorContext.java:61) [resteasy-jaxrs-3.0.19.Final.jar:3.0.19.Final]
	at org.jboss.resteasy.core.interception.ServerReaderInterceptorContext.readFrom(ServerReaderInterceptorContext.java:60) [resteasy-jaxrs-3.0.19.Final.jar:3.0.19.Final]

Comment 3 Egor 2017-01-27 11:43:49 UTC
Created attachment 1245100 [details]
New error message box

I had to update packages on the server, because of this bug: https://bugzilla.redhat.com/show_bug.cgi?id=1415808

Now I receive Internal Engine Error after I try to create virtual machine itself (this time there is no error when creating disk image).

I will attach logs in the next comment (because, for some reason I cannot attach several files at the same time).

Comment 4 Egor 2017-01-27 11:49:17 UTC
Created attachment 1245103 [details]
Internal Engine Error logs

The logs on the ovirt-engine host after getting Internal Server Error.

I have executed the command 'yum install ovirt-engine-webadmin-portal-debuginfo ovirt-engine-userportal-debuginfo' and restarted the server before trying to create virtual machine.

Comment 5 Egor 2017-01-27 12:48:55 UTC
Now it looks like I cannot create any virtual machine (even without creating disks). The logs above are still relevant.

Comment 6 Egor 2017-01-27 13:54:30 UTC
Created attachment 1245155 [details]
Python script log

I've tried to create virtual machine with the following script: https://github.com/oVirt/ovirt-engine-sdk/blob/master/sdk/examples/add_vm.py

And I get the same error:
...
DEBUG:root:<fault>
DEBUG:root:    <detail>[Internal Engine Error]</detail>
DEBUG:root:    <reason>Operation Failed</reason>
DEBUG:root:</fault>
...

Comment 7 Greg Sheremeta 2017-01-27 14:32:47 UTC
I see the following in engine.log that explains why your create VM is failing:

2017-01-27 14:38:55,060 ERROR [org.ovirt.engine.core.bll.AddVmCommand] (default task-19) [] Exception: org.springframework.dao.InvalidDataAccessApiUsageException: Required input parameter 'v_guest_mem_free' is missing
	at org.springframework.jdbc.core.CallableStatementCreatorFactory$CallableStatementCreatorImpl.createCallableStatement(CallableStatementCreatorFactory.java:211) [spring-jdbc.jar:4.2.4.RELEASE]
	at org.springframework.jdbc.core.JdbcTemplate.execute(JdbcTemplate.java:1072) [spring-jdbc.jar:4.2.4.RELEASE]
	at org.springframework.jdbc.core.JdbcTemplate.call(JdbcTemplate.java:1130) [spring-jdbc.jar:4.2.4.RELEASE]
	at org.springframework.jdbc.core.simple.AbstractJdbcCall.executeCallInternal(AbstractJdbcCall.java:405) [


Assigning to virt team for investigation.

Comment 8 Shahar Havivi 2017-02-01 08:39:39 UTC
Hi Egor,

as I see in the engine.log you an error regarding 'v_guest_mem_free' db field which is removed.
We cannot reproduce your error in several environments.

What exactly is the problem you encounter?
You cannot add disk at all?
Can you test a different setup?

Comment 9 Tomas Jelinek 2017-02-01 10:16:30 UTC
also, what is the exact version of your engine please? Where did you get it from?

Comment 10 Egor 2017-02-01 15:46:57 UTC
Created attachment 1246696 [details]
Requested data for bug

Files 'action_1.png', 'action_2.png', 'action_3.png' depict the actions that lead me to internal server error.

Where do I get ovirt from?
First, I have downloaded an image from ovirt.org.
After that in a different bug I was asked to update my version of ovirt by performing command: 'dnf update ovirt-engine'.
That is all I did what could affect ovirt version of ovirt binaries.
In the file 'ovirt-version.txt' you can look at the version of all of the packages that I have.

In the folders 'ovirt-*' there should be all of the log files necessary to determine the cause of the problem (if you log enough info).

Comment 11 Tomas Jelinek 2017-02-03 19:38:07 UTC
hmm, and did you run engine-setup after running dnf update? because engine-setup updates your database and the symptoms here look like the DB is not updated.

Comment 12 Egor 2017-02-06 16:13:28 UTC
(In reply to Tomas Jelinek from comment #11)
> hmm, and did you run engine-setup after running dnf update? because
> engine-setup updates your database and the symptoms here look like the DB is
> not updated.

No, I didn't run 'engine-setup' after 'dnf update'. But now, after did it, everything is working. I am sorry for taking your time, but this wasn't obvious for me.

Thank you!


Note You need to log in before you can comment on or make changes to this bug.