Bug 1416481 - IPA replica install fails with dirsrv errors.
Summary: IPA replica install fails with dirsrv errors.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Pavel Picka
QA Contact: Kaleem
Marc Muehlfeld
URL:
Whiteboard:
Depends On: 1398600
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 15:25 UTC by Jaroslav Reznik
Modified: 2020-05-14 15:34 UTC (History)
21 users (show)

Fixed In Version: ipa-4.4.0-14.el7_3.5
Doc Type: If docs needed, set a value
Doc Text:
Previously, the Identity Management (IdM) public key infrastructure (PKI) component was configured to listen on the "::1" IPv6 localhost address. In environments have the the IPv6 protocol disabled, the replica installer was unable to retrieve the Directory Server certificate, and the installation failed. The default listening address of the PKI connector has been updated from the IP address to "localhost". As a result, the PKI connector now listens on the correct addresses in IPv4 and IPv6 environments.
Clone Of: 1398600
Environment:
Last Closed: 2017-03-02 17:26:20 UTC
Target Upstream Version:


Attachments (Terms of Use)
IPA patch (1.79 KB, patch)
2017-01-25 15:55 UTC, Tomas Krizek
no flags Details | Diff
evidence (16.21 KB, text/plain)
2017-02-06 12:32 UTC, Pavel Picka
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Article) 2852231 None None None 2017-01-25 15:25:29 UTC
Red Hat Product Errata RHSA-2017:0388 normal SHIPPED_LIVE Moderate: ipa security and bug fix update 2017-03-02 22:06:32 UTC

Description Jaroslav Reznik 2017-01-25 15:25:16 UTC
This bug has been copied from bug #1398600 and has been proposed
to be backported to 7.3 z-stream (EUS).

Comment 3 Tomas Krizek 2017-01-25 15:55:10 UTC
Created attachment 1244294 [details]
IPA patch

Attaching the patch for IPA-side in this BZ as well. Please note that the patch from bug #1413136 is required for our patch to work properly.

Comment 8 Pavel Picka 2017-02-06 12:32:36 UTC
Created attachment 1248026 [details]
evidence

Verified 4.4.0-14.el7_3.6.x86_64

Comment 10 errata-xmlrpc 2017-03-02 17:26:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHSA-2017-0388.html


Note You need to log in before you can comment on or make changes to this bug.