Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1416486 - [RFE] OpenShift Projects report Pods: Deleted On attribute empty
Summary: [RFE] OpenShift Projects report Pods: Deleted On attribute empty
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.8.0
Assignee: zakiva
QA Contact: Einat Pacifici
URL:
Whiteboard: container:report:pod
Depends On:
Blocks: 1428130
TreeView+ depends on / blocked
 
Reported: 2017-01-25 15:32 UTC by ncatling
Modified: 2017-06-12 17:54 UTC (History)
7 users (show)

Fixed In Version: 5.8.0.3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1428130 (view as bug list)
Environment:
Last Closed: 2017-06-12 17:54:17 UTC
Category: ---
Cloudforms Team: Container Management
Target Upstream Version:


Attachments (Terms of Use)

Description ncatling 2017-01-25 15:32:13 UTC
Description of problem:
OpenShift 'Projects' based report 'Pods: Deleted On' attribute is empty, however 'Pods' based report 'Deleted On' contains the expected data.

Version-Release number of selected component (if applicable):
5.7.0.17.20161219135818_725f92f
OCP 3.3

How reproducible:


Steps to Reproduce:
1. Create 'Projects' based report 'Pods: Deleted On' field selected; no data found.
2. Create 'Pods' based report with 'Deleted On' selected and the expected data exists.
3.

Actual results:


Expected results:


Additional info:

Comment 2 zakiva 2017-02-08 14:16:54 UTC
This issue is caused by the fact that container groups that were "deleted" (with 'Deleted On' field as described above), are archived pods and thus still exist in the Container Groups table. However, we remove the connection between the container project and his container groups once they are archived. Therefore, a project report based on 'Pods: Deleted On' does not contain any data.
I created this PR: https://github.com/ManageIQ/manageiq/pull/13810 in order to support the use case of viewing a project report that includes the ARCHIVED container groups of the project by basing the report on "Archived Container Groups:<field>".

Comment 3 Federico Simoncelli 2017-02-13 10:30:29 UTC
Nick, can you take a look at the PR:

https://github.com/ManageIQ/manageiq/pull/13810

and the screenshot?

IIRC current implementation will allow you to do:

- Reports with *only* active pods (*no* archived pods) and *no* DeletedOn value (as it is now, no changes here)

- Reports with *only* archived pods and *no* active pods but with DeletedOn value available (what we introduced into the PR).


But you will *not* be able to mix the two in a single report.

Nick, is that acceptable?


This is not just "a field is missing" type of bug as in the description, here we have to build a valuable use-case.

Loic any insight?

Comment 4 Federico Simoncelli 2017-02-13 10:34:51 UTC
(In reply to Federico Simoncelli from comment #3)
> 
> But you will *not* be able to mix the two in a single report.

Actually I'll leave this to Zahi to comment because I have the feeling I may be wrong on that (maybe you can mix them).

Comment 5 Federico Simoncelli 2017-02-21 16:30:13 UTC
(In reply to Federico Simoncelli from comment #4)
> (In reply to Federico Simoncelli from comment #3)
> > 
> > But you will *not* be able to mix the two in a single report.
> 
> Actually I'll leave this to Zahi to comment because I have the feeling I may
> be wrong on that (maybe you can mix them).

Zahi confirmed this today in the PR.

Nick/Loic can you check what comment 3 states and if it's what you expected?
Thanks.

Comment 6 ncatling 2017-02-24 14:45:35 UTC
The use case is create a daily project based report, showing pods (including their name) deleted by project. The screenshots in the PR look good.

Comment 8 Einat Pacifici 2017-03-23 12:08:54 UTC
Verified. Generated report as in PR 
https://github.com/ManageIQ/manageiq/pull/13810

Deleted on date field is populated in generated report.


Note You need to log in before you can comment on or make changes to this bug.