Bug 1416497 - Undercloud upgrade fails with Error: Evaluation Error: Error while evaluating a Resource Statement, Could not find declared class ::panko::db::mysql
Summary: Undercloud upgrade fails with Error: Evaluation Error: Error while evaluating...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 11.0 (Ocata)
Assignee: Steve Linabery
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 15:58 UTC by Marius Cornea
Modified: 2017-05-17 19:43 UTC (History)
9 users (show)

Fixed In Version: openstack-puppet-modules-9.4.0-0.20170111174831.8c758d6.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 19:43:22 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC

Description Marius Cornea 2017-01-25 15:58:40 UTC
Description of problem:
Undercloud upgrade fails with:

Error: Evaluation Error: Error while evaluating a Resource Statement, Could not find declared class ::panko::db::mysql at /etc/puppet/manifests/puppet-stack-config.pp:229:3 on node undercloud-0.redhat.local


Version-Release number of selected component (if applicable):
instack-undercloud-6.0.0-0.20170120171137.c891931.el7ost.noarch
instack-5.0.1-0.20170118105302.b562d77.el7ost.noarch
python-tripleoclient-5.7.1-0.20170119215047.22d0209.el7ost.noarch
openstack-tripleo-common-5.7.1-0.20170120161758.35bdc3b.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Upgrade undercloud 

Actual results:
Upgrade fails

Expected results:
Upgrade succeeds

Additional info:
Workaround:

yum install -y puppet-panko

then rerun undercloud upgrade

Comment 1 Marius Cornea 2017-01-25 16:36:25 UTC
It appears that the openstack-puppet-modules version in OSP11 is < OSP10 hence the package doesn't get updated:

OSP10:
openstack-puppet-modules-9.3.0-1.el7ost.noarch

OSP11:
openstack-puppet-modules-9.3.0-0.20170111174831.8c758d6.el7ost.noarch.rpm

Comment 4 errata-xmlrpc 2017-05-17 19:43:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.