Bug 1416502 - Undercloud upgrade fails during aodh-db-sync: ProgrammingError: (pymysql.err.ProgrammingError) (1146, u"Table 'ceilometer.alarm_change' doesn't exist") [SQL: u'ALTER TABLE alarm_change ADD COLUMN timestamp_ts DATETIME(6)']
Summary: Undercloud upgrade fails during aodh-db-sync: ProgrammingError: (pymysql.err....
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Pradeep Kilambi
QA Contact: Omri Hochman
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 16:12 UTC by Marius Cornea
Modified: 2017-05-17 19:43 UTC (History)
10 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-05-17 19:43:26 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 424950 None None None 2017-01-25 16:12 UTC

Description Marius Cornea 2017-01-25 16:12:36 UTC
Description of problem:
Undercloud upgrade fails during aodh-db-sync: ProgrammingError: (pymysql.err.ProgrammingError) (1146, u"Table 'ceilometer.alarm_change' doesn't exist") [SQL: u'ALTER TABLE alarm_change ADD COLUMN timestamp_ts DATETIME(6)']

Version-Release number of selected component (if applicable):
instack-undercloud-6.0.0-0.20170120171137.c891931.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Upgrade undercloud

Actual results:
Fails during aodh-db-sync:

2017-01-25 11:00:17,233 INFO: Error: /Stage[main]/Aodh::Db::Sync/Exec[aodh-db-sync]/returns: change from notrun to 0 failed: aodh-dbsync --config-file /etc/aodh/aodh.conf returned 1 instead of one of [0]
 

Expected results:
Upgrade completes ok.

Additional info:

Comment 1 Julien Danjou 2017-01-26 13:45:33 UTC
The question is: why is Ceilometer database referenced here?

Comment 8 errata-xmlrpc 2017-05-17 19:43:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.