Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1416516 - ifcfg-rh primary secondary order
Summary: ifcfg-rh primary secondary order
Keywords:
Status: CLOSED DUPLICATE of bug 1394500
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Beniamino Galvani
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 16:45 UTC by Christoph
Modified: 2017-01-27 13:00 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-27 13:00:34 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Christoph 2017-01-25 16:45:25 UTC
Description of problem:

using old style ifcfg-eno1 (using dhcp) and ifcfg-eno1:1 (adding a secondary static ip) as configuration files in /etc/sysconfig.

Starting with the old network.service, the dhcp address is the primary ip and the static configured ip is secondary. 

Starting with the NetworkManager.service, the dhcp address becomes the secondary ip. 


Version-Release number of selected component (if applicable):


NetworkManager-1.4.0-14.el7_3.x86_64
initscripts-9.49.37-1.el7.x86_64


How reproducible:

always


Steps to Reproduce:
1. place /etc/sysconfig/network/scripts-ifcfg-eno1
DEVICE="eno1"
NAME="eno1"
ONBOOT="yes"
BOOTPROTO="dhcp"
PERSISTENT_DHCLIENT="yes"
IPV6INIT="no"
PEERDNS="yes"

2. place /etc/sysconfig/network/scripts-ifcfg-eno1:1
DEVICE="eno1:1"
NAME="eno1:1"
ONBOOT="yes"
IPADDR="192.168.10.100"
NETMASK="255.255.255.0"
IPV6INIT="no"


3. systemctl enable NetworkManager.service

4. reboot


Actual results:

ip a 

2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether x brd ff:ff:ff:ff:ff:ff
    inet 192.168.10.100/24 brd 192.168.10.255 scope global primary eno1:1
       valid_lft forever preferred_lft forever
    inet 192.168.10.2/24 brd 192.168.10.255 scope global secondary dynamic 
       valid_lft 517796sec preferred_lft 517796sec


Expected results:

ip a 

2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether x brd ff:ff:ff:ff:ff:ff
    inet 192.168.10.2/24 brd 192.168.10.255 scope global primary dynamic 
       valid_lft 517796sec preferred_lft 517796sec
    inet 192.168.10.100/24 brd 192.168.10.255 scope global secondary eno1:1
       valid_lft forever preferred_lft forever

Comment 1 Thomas Haller 2017-01-25 17:39:44 UTC
I think this is a duplicate of bug 1394500.
Beniamino?

Comment 3 Beniamino Galvani 2017-01-27 13:00:34 UTC
(In reply to Thomas Haller from comment #1)
> I think this is a duplicate of bug 1394500.
> Beniamino?

Yes, it's the same bug; IP addresses are being sorted by source/value before they are applied.

I'm closing this as duplicate.

*** This bug has been marked as a duplicate of bug 1394500 ***


Note You need to log in before you can comment on or make changes to this bug.