Bug 1416519 - Deployment fails when Neutron services run on a dedicated role
Summary: Deployment fails when Neutron services run on a dedicated role
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Emilien Macchi
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 16:58 UTC by Marius Cornea
Modified: 2017-05-17 19:43 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-heat-templates-6.0.0-7.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 19:43:32 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 425941 None None None 2017-01-26 21:48:53 UTC
OpenStack gerrit 425942 None None None 2017-01-26 21:51:34 UTC
OpenStack gerrit 426045 None None None 2017-01-27 03:55:05 UTC
OpenStack gerrit 426046 None None None 2017-01-27 03:55:29 UTC
Launchpad 1659662 None None None 2017-01-26 21:49:09 UTC

Description Marius Cornea 2017-01-25 16:58:12 UTC
Description of problem:
Deployment fails when Neutron services run on a dedicated role:

stdout: overcloud.AllNodesDeploySteps.NeutronDeployment_Step4:
  resource_type: OS::Heat::StructuredDeploymentGroup
  physical_resource_id: 86e3e197-ea8a-41a1-95a2-3b948e533e84
  status: CREATE_FAILED
  status_reason: |
    CREATE aborted
overcloud.AllNodesDeploySteps.ControllerDeployment_Step4:
  resource_type: OS::Heat::StructuredDeploymentGroup
  physical_resource_id: a2a87417-3834-4365-a497-efef4040de32
  status: CREATE_FAILED
  status_reason: |
    CREATE aborted
overcloud.AllNodesDeploySteps.ServiceApiDeployment_Step4.1:
  resource_type: OS::Heat::StructuredDeployment
  physical_resource_id: 0fcc0b95-ba8f-4c72-9a0b-8c8425430210
  status: CREATE_FAILED
  status_reason: |
    Error: resources[1]: Deployment to server failed: deploy_status_code : Deployment exited with non-zero status code: 1
  deploy_stdout: |
    Notice: hiera(): Cannot load backend module_data: cannot load such file -- hiera/backend/module_data_backend
  deploy_stderr: |
    ...
    Warning: Unknown variable: '::snmp_trap_service_hasrestart'. at /etc/puppet/modules/snmp/manifests/params.pp:270:30
    Warning: ModuleLoader: module 'timezone' has unresolved dependencies - it will only see those that are resolved. Use 'puppet module list --tree' to see information about modules
       (file & line not available)
    Warning: Scope(Class[Ceilometer]): Both $metering_secret and $telemetry_secret defined, using $telemetry_secret
    Warning: Scope(Class[Ceilometer]): ceilometer::rabbit_host, ceilometer::rabbit_hosts, ceilometer::rabbit_password, ceilometer::rabbit_port, ceilometer::rabbit_userid and ceilometer::rabbit_virtual_host are deprecated. Please use ceilometer::default_transport_url instead.
    Warning: Scope(Class[Ceilometer::Api]): ceilometer-api has been deprecated in Ocata and will be removed in future. Please use Aodh, Gnocchi and Panko modules instead.
    Warning: This method is deprecated, please use match expressions with Stdlib::Compat::Ip_address instead. They are described at https://docs.puppet.com/puppet/latest/reference/lang_data_type.html#match-expressions. at ["/var/lib/heat-config/heat-config-puppet/d6f433aa-c5a9-437b-92c0-1c8410a6a8d0.pp", 69]:["/etc/puppet/modules/tripleo/manifests/profile/base/ceilometer/collector.pp", 84]
       (at /etc/puppet/modules/stdlib/lib/puppet/functions/deprecation.rb:25:in `deprecation')
    Warning: Scope(Class[Ceilometer::Agent::Central]): This class is deprecated. Please use ceilometer::agent::central with central namespace instead.
    Error: Evaluation Error: Error while evaluating a Function Call, Could not find data item neutron::plugins::ml2::mechanism_drivers in any Hiera data file and no default supplied at /etc/puppet/modules/tripleo/manifests/profile/base/horizon.pp:33:24 on node overcloud-serviceapi-1.localdomain
    (truncated, view all with --long)
overcloud.AllNodesDeploySteps.ServiceApiDeployment_Step4.0:
  resource_type: OS::Heat::StructuredDeployment
  physical_resource_id: db7f1287-6005-44ee-afc2-6a0ce513baff
  status: CREATE_FAILED
  status_reason: |
    Error: resources[0]: Deployment to server failed: deploy_status_code : Deployment exited with non-zero status code: 1
  deploy_stdout: |
    Notice: hiera(): Cannot load backend module_data: cannot load such file -- hiera/backend/module_data_backend
  deploy_stderr: |
    ...
    Warning: Unknown variable: '::snmp_trap_service_hasrestart'. at /etc/puppet/modules/snmp/manifests/params.pp:270:30
    Warning: ModuleLoader: module 'timezone' has unresolved dependencies - it will only see those that are resolved. Use 'puppet module list --tree' to see information about modules
       (file & line not available)
    Warning: Scope(Class[Ceilometer]): Both $metering_secret and $telemetry_secret defined, using $telemetry_secret
    Warning: Scope(Class[Ceilometer]): ceilometer::rabbit_host, ceilometer::rabbit_hosts, ceilometer::rabbit_password, ceilometer::rabbit_port, ceilometer::rabbit_userid and ceilometer::rabbit_virtual_host are deprecated. Please use ceilometer::default_transport_url instead.
    Warning: Scope(Class[Ceilometer::Api]): ceilometer-api has been deprecated in Ocata and will be removed in future. Please use Aodh, Gnocchi and Panko modules instead.
    Warning: This method is deprecated, please use match expressions with Stdlib::Compat::Ip_address instead. They are described at https://docs.puppet.com/puppet/latest/reference/lang_data_type.html#match-expressions. at ["/var/lib/heat-config/heat-config-puppet/10356737-e69e-42cc-b2fe-8274a5ba849f.pp", 69]:["/etc/puppet/modules/tripleo/manifests/profile/base/ceilometer/collector.pp", 84]
       (at /etc/puppet/modules/stdlib/lib/puppet/functions/deprecation.rb:25:in `deprecation')
    Warning: Scope(Class[Ceilometer::Agent::Central]): This class is deprecated. Please use ceilometer::agent::central with central namespace instead.
    Error: Evaluation Error: Error while evaluating a Function Call, Could not find data item neutron::plugins::ml2::mechanism_drivers in any Hiera data file and no default supplied at /etc/puppet/modules/tripleo/manifests/profile/base/horizon.pp:33:24 on node overcloud-serviceapi-0.localdomain
    (truncated, view all with --long)
overcloud.AllNodesDeploySteps.ServiceApiDeployment_Step4.2:
  resource_type: OS::Heat::StructuredDeployment
  physical_resource_id: 78c30c12-d7f0-4041-88af-1233091819de
  status: CREATE_FAILED
  status_reason: |
    Error: resources[2]: Deployment to server failed: deploy_status_code : Deployment exited with non-zero status code: 1
  deploy_stdout: |
    Notice: hiera(): Cannot load backend module_data: cannot load such file -- hiera/backend/module_data_backend
  deploy_stderr: |
    ...
    Warning: Unknown variable: '::snmp_trap_service_hasrestart'. at /etc/puppet/modules/snmp/manifests/params.pp:270:30
    Warning: ModuleLoader: module 'timezone' has unresolved dependencies - it will only see those that are resolved. Use 'puppet module list --tree' to see information about modules
       (file & line not available)
    Warning: Scope(Class[Ceilometer]): Both $metering_secret and $telemetry_secret defined, using $telemetry_secret
    Warning: Scope(Class[Ceilometer]): ceilometer::rabbit_host, ceilometer::rabbit_hosts, ceilometer::rabbit_password, ceilometer::rabbit_port, ceilometer::rabbit_userid and ceilometer::rabbit_virtual_host are deprecated. Please use ceilometer::default_transport_url instead.
    Warning: Scope(Class[Ceilometer::Api]): ceilometer-api has been deprecated in Ocata and will be removed in future. Please use Aodh, Gnocchi and Panko modules instead.
    Warning: This method is deprecated, please use match expressions with Stdlib::Compat::Ip_address instead. They are described at https://docs.puppet.com/puppet/latest/reference/lang_data_type.html#match-expressions. at ["/var/lib/heat-config/heat-config-puppet/43f775b3-9ff3-43be-9196-c4833888ef10.pp", 69]:["/etc/puppet/modules/tripleo/manifests/profile/base/ceilometer/collector.pp", 84]
       (at /etc/puppet/modules/stdlib/lib/puppet/functions/deprecation.rb:25:in `deprecation')
    Warning: Scope(Class[Ceilometer::Agent::Central]): This class is deprecated. Please use ceilometer::agent::central with central namespace instead.
    Error: Evaluation Error: Error while evaluating a Function Call, Could not find data item neutron::plugins::ml2::mechanism_drivers in any Hiera data file and no default supplied at /etc/puppet/modules/tripleo/manifests/profile/base/horizon.pp:33:24 on node overcloud-serviceapi-2.localdomain
    (truncated, view all with --long)
overcloud.AllNodesDeploySteps.ComputeDeployment_Step4:
  resource_type: OS::Heat::StructuredDeploymentGroup
  physical_resource_id: d6b9aead-a4b5-426d-b749-840aec2f5170
  status: CREATE_FAILED
  status_reason: |
    CREATE aborted
overcloud.AllNodesDeploySteps.ObjectStorageDeployment_Step4:
  resource_type: OS::Heat::StructuredDeploymentGroup
  physical_resource_id: a48d4a63-fb65-4ae3-856c-e29138a29a70
  status: CREATE_FAILED
  status_reason: |
    CREATE aborted
overcloud.AllNodesDeploySteps.CephStorageDeployment_Step4:
  resource_type: OS::Heat::StructuredDeploymentGroup
  physical_resource_id: 897e4253-e55b-49d5-81c1-5009ceb37dfd
  status: CREATE_FAILED
  status_reason: |
    CREATE aborted

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-6.0.0-0.20170120220933.36d493c.el7ost.noarch
puppet-tripleo-6.1.0-0.20170121023916.1f66b8b.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:

1. Deploy overcloud with custom roles with Neutron services on a separated node:
source ~/stackrc
export THT=/usr/share/openstack-tripleo-heat-templates/

openstack overcloud deploy --templates $THT \
-r ~/openstack_deployment/roles/roles_data.yaml \
-e $THT/environments/puppet-pacemaker.yaml \
-e $THT/environments/network-isolation.yaml \
-e $THT/environments/network-management.yaml \
-e $THT/environments/storage-environment.yaml \
-e ~/openstack_deployment/environments/nodes.yaml \
-e ~/openstack_deployment/environments/network-environment.yaml \
-e ~/openstack_deployment/environments/disk-layout.yaml \
-e ~/openstack_deployment/environments/neutron-settings.yaml \
--log-file overcloud_deployment.log &> overcloud_install.log

Actual results:
Deployment fails.

Expected results:


Additional info:

Environment files:
http://paste.openstack.org/show/596485/

Comment 1 Emilien Macchi 2017-03-01 20:08:18 UTC
Hey Marius, patches have been merged and it's probably in downstream builds. Can you check if it's fine for you now?

Thanks!

Comment 4 errata-xmlrpc 2017-05-17 19:43:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.