Bug 1416520 - Missing FOPs in the io-stats xlator
Summary: Missing FOPs in the io-stats xlator
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: io-stats
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Menaka
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 17:06 UTC by Menaka
Modified: 2017-05-30 18:39 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.11.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-30 18:39:31 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Menaka 2017-01-25 17:06:22 UTC
Description of problem: The following FOPs are not implemented in the io-stats xlator.
1.fentrylk
2.compound
3.seek
4.lease
5.getactivelk
6.setactivelk

Comment 2 Shyamsundar 2017-01-31 13:36:59 UTC
This is being worked on as a part of the Outreachy project by Menaka Mohan, and hence is assigned to her.

An initial patch is posted @https://review.gluster.org/#/c/16490/ which will be corrected to reflect this bug soon.

Comment 3 Worker Ant 2017-02-03 13:23:55 UTC
REVIEW: https://review.gluster.org/16490 (Adding the missing FOPs in the io-stats xlator) posted (#2) for review on master by Menaka Mohan (menaka.m@outlook.com)

Comment 4 Worker Ant 2017-02-03 13:39:52 UTC
REVIEW: https://review.gluster.org/16490 (Added the missing FOPs in the io-stats xlator) posted (#3) for review on master by Menaka Mohan (menaka.m@outlook.com)

Comment 5 Worker Ant 2017-02-06 02:44:57 UTC
COMMIT: https://review.gluster.org/16490 committed in master by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 6bd86b7085098c79ee6a50015fe89a8b18608cbf
Author: menakamohan <menaka.m@outlook.com>
Date:   Tue Jan 31 17:14:30 2017 +0530

    Added the missing FOPs in the io-stats xlator
    
    The following FOPs are not implemented in the io-stats xlator.
    1)fentrylk
    2)compound
    3)seek
    4)lease
    5)getactivelk
    6)setactivelk
    
    Added the missing FOPs to the io-stats xlator
    
    Change-Id: I4577f82ec906f1b88327c484cd9a6f356d578125
    BUG: 1416520
    Signed-off-by: menakamohan <menaka.m@outlook.com>
    Reviewed-on: https://review.gluster.org/16490
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>

Comment 6 Shyamsundar 2017-05-30 18:39:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.0, please open a new bug report.

glusterfs-3.11.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-May/000073.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.