Bug 1416527 - hyperv postinstall scripts create /1 file
Summary: hyperv postinstall scripts create /1 file
Keywords:
Status: CLOSED DUPLICATE of bug 1414822
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: hyperv-daemons
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Vitaly Kuznetsov
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 17:23 UTC by Zdenek Juran
Modified: 2017-01-26 09:58 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-26 09:58:42 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Zdenek Juran 2017-01-25 17:23:37 UTC
Description of problem:
postinstall rpm scripts are wrong
There is change in the if condition from version 7.2 "if [ $1 -eq 1 ]" to version 7.3 "if [ $1 > 1 ]" but the fix should be: "if [ $1 -gt 1 ]"

Version-Release number of selected component (if applicable):
affected RPM packages:
1. hypervfcopyd-0-0.29.20160216git.el7.x86_64.rpm
2. hypervkvpd-0-0.29.20160216git.el7.x86_64.rpm
3. hypervvssd-0-0.29.20160216git.el7.x86_64.rpm

How reproducible:
always


Steps to Reproduce:
1. install these packages
2. check root folder for existence of /1 file

Actual results:
The if condition is wrongly evaluated. So, the body of the condition is processed in wrong circumstances

Expected results:
Fix the condition to test integer value and run condition body only for upgrade

Comment 1 Zdenek Juran 2017-01-25 17:34:08 UTC
As a side effect related hyperv services become disabled

Comment 2 Vitaly Kuznetsov 2017-01-26 09:58:42 UTC
(In reply to Zdenek Juran from comment #0)
> Description of problem:
> postinstall rpm scripts are wrong
> There is change in the if condition from version 7.2 "if [ $1 -eq 1 ]" to
> version 7.3 "if [ $1 > 1 ]" but the fix should be: "if [ $1 -gt 1 ]"
> 

Yes, this is https://bugzilla.redhat.com/show_bug.cgi?id=1414822

(In reply to Zdenek Juran from comment #1)
> As a side effect related hyperv services become disabled

Hyper-V services are *supposed* to become disabled as we have udev activation now. This is what these postinstall scripts are for.

*** This bug has been marked as a duplicate of bug 1414822 ***


Note You need to log in before you can comment on or make changes to this bug.