Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1416533 - oVirt Guest Tools for Windows: Balloon Service Fails to start due to incorrect path set by installer
Summary: oVirt Guest Tools for Windows: Balloon Service Fails to start due to incorrec...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-guest-tools
Classification: oVirt
Component: Packaging.installer
Version: 4.1.0
Hardware: x86_64
OS: Windows
unspecified
unspecified
Target Milestone: ovirt-4.1.0-rc
: 4.1.0
Assignee: Yedidyah Bar David
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks: 1416579
TreeView+ depends on / blocked
 
Reported: 2017-01-25 18:06 UTC by Daniel Beckman
Modified: 2017-05-11 09:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-15 15:03:40 UTC
oVirt Team: Integration
rule-engine: ovirt-4.1+
rule-engine: exception+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 71226 0 master MERGED Fix driver path for win2k* 2017-01-26 14:38:52 UTC
oVirt gerrit 71265 0 ovirt-wgt-4.1 MERGED Fix driver path for win2k* 2017-01-26 14:58:20 UTC

Description Daniel Beckman 2017-01-25 18:06:19 UTC
Description of problem:
When installing oVirt Guest Tools on a Windows Server 2012 R2 (x64) VM from the oVirt tools ISO, the installer (ovirt-guest-tools-setup.exe) installs the Balloon Service with the wrong path. It sets the path as follows:
C:\Program Files (x86)\oVirt Guest Tools\drivers\Balloon\w2k12R2\amd64\blnsvr.exe"
But the correct path (where the files are installed) is here:
C:\Program Files (x86)\oVirt Guest Tools\drivers\Balloon\2k12R2\amd64\blnsvr.exe"
Note the apparent "typo" in "w2k12R2" vs. "2k12R2". 
As a result, the Balloon Service fails to start. The ISO I used is found here:
http://resources.ovirt.org/pub/ovirt-4.1-pre/iso/oVirt-toolsSetup/4.1-1.fc24/
However, note that this issue has been present beginning with much earlier versions of oVirt Guest Tools, going back to at least oVirt 3.6. It has been mentioned several instances on the oVirt users mailling list, but I was not able to find a corresponding bug. 

Version-Release number of selected component (if applicable):
4.1-1.fc24
(But it's also in earlier versions as noted above.)

How reproducible:
100%

Steps to Reproduce:
1. Attach latest (or any version 3.6+) oVirt Guest Tools ISO to VM
2. From VM run executable ovirt-guest-tools-setup.exe on virtual CD drive
3. From Computer Management --> Services, check the Balloon Service. Note that it is not running and it references a non-existent path. Attempting to start it manually will result in an error due to invalid path. 


Actual results:
Balloon Service does not start

Expected results:
Balloon Service starts automatically

Additional info:
A workaround is to start a command prompt as Administrator and run the following command:
sc config BalloonService binpath= "C:\Program Files (x86)\oVirt Guest Tools\drivers\Balloon\2k12R2\amd64\blnsvr.exe" DisplayName= "Balloon Service" start= auto
The Balloon Service will now start.

Comment 1 Christophe Fergeau 2017-01-26 07:48:03 UTC
Sent https://lists.freedesktop.org/archives/spice-devel/2017-January/035215.html upstream for that issue.

Comment 2 Daniel Beckman 2017-01-26 20:50:22 UTC
Please see my recent comments from related bug:
https://bugzilla.redhat.com/show_bug.cgi?id=1416579
As suspected, they have the same underlying issue and are corrected with a recent build of oVirt Guest Tools:
http://jenkins.ovirt.org/job/ovirt-wgt_master_create-rpms-fc24-x86_64_created/22/


Note You need to log in before you can comment on or make changes to this bug.