Bug 1416553 - [abrt] xorg-x11-server-Xwayland: Segmentation fault at address 0x20
Summary: [abrt] xorg-x11-server-Xwayland: Segmentation fault at address 0x20
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:05c9cce427379ebb80f98b6d81e...
: 1414523 1430894 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 19:22 UTC by Alec
Modified: 2017-04-01 00:25 UTC (History)
7 users (show)

Fixed In Version: xorg-x11-server-1.19.3-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-01 00:25:12 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.02 KB, text/plain)
2017-01-25 19:22 UTC, Alec
no flags Details
File: dmesg (65.49 KB, text/plain)
2017-01-25 19:22 UTC, Alec
no flags Details
File: dso_list (407 bytes, text/plain)
2017-01-25 19:22 UTC, Alec
no flags Details
File: etc_X11_xorg_conf_d.tar.gz (330 bytes, application/octet-stream)
2017-01-25 19:22 UTC, Alec
no flags Details
File: usr_share_xorg_conf_d.tar.gz (2.07 KB, application/octet-stream)
2017-01-25 19:22 UTC, Alec
no flags Details


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 99149 None None None 2017-03-02 08:32:12 UTC
FreeDesktop.org 100040 None None None 2017-03-10 08:17:30 UTC

Description Alec 2017-01-25 19:22:25 UTC
Version-Release number of selected component:
xorg-x11-server-Xwayland-1.19.1-2.fc25

Additional info:
reporter:       libreport-2.8.0
executable:     /usr/bin/Xwayland
kernel:         4.9.5-200.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       unknown
type:           xorg
uid:            0

Truncated backtrace:
0: /usr/bin/Xwayland (OsLookupColor+0x139) [0x5909c9]
1: /lib64/libpthread.so.0 (__restore_rt+0x0) [0x7f7ece7a45bf]
2: /usr/bin/Xwayland (WriteFdToClient+0x4) [0x58fb94]
3: /usr/bin/Xwayland (dri3_send_open_reply+0x6d) [0x4f123d]
4: /usr/bin/Xwayland (InitExtensions+0x657) [0x42ab17]
5: /lib64/libffi.so.6 (ffi_call_unix64+0x4c) [0x7f7ecdd41c58]
6: /lib64/libffi.so.6 (ffi_call+0x32a) [0x7f7ecdd416ba]
7: /lib64/libwayland-client.so.0 (wl_log_set_handler_client+0x1c9e) [0x7f7ed058a80e]
8: /lib64/libwayland-client.so.0 (_init+0x850) [0x7f7ed05860e0]
9: /lib64/libwayland-client.so.0 (wl_display_dispatch_queue_pending+0x74) [0x7f7ed0586be4]
10: /usr/bin/Xwayland (_start+0x92b) [0x424fab]
11: /usr/bin/Xwayland (OsCleanup+0x641) [0x591931]
12: /usr/bin/Xwayland (WaitForSomething+0xcc) [0x58ab9c]
13: /usr/bin/Xwayland (SendErrorToClient+0x13a) [0x55668a]
14: /usr/bin/Xwayland (InitFonts+0x428) [0x55a898]
15: /lib64/libc.so.6 (__libc_start_main+0xf1) [0x7f7ece3ed401]
16: /usr/bin/Xwayland (_start+0x2a) [0x423dba]
17: ? (?+0x2a) [0x2a]

Comment 1 Alec 2017-01-25 19:22:28 UTC
Created attachment 1244390 [details]
File: backtrace

Comment 2 Alec 2017-01-25 19:22:29 UTC
Created attachment 1244391 [details]
File: dmesg

Comment 3 Alec 2017-01-25 19:22:30 UTC
Created attachment 1244392 [details]
File: dso_list

Comment 4 Alec 2017-01-25 19:22:31 UTC
Created attachment 1244393 [details]
File: etc_X11_xorg_conf_d.tar.gz

Comment 5 Alec 2017-01-25 19:22:32 UTC
Created attachment 1244394 [details]
File: usr_share_xorg_conf_d.tar.gz

Comment 8 Olivier Fourdan 2017-03-10 08:19:45 UTC
*** Bug 1414523 has been marked as a duplicate of this bug. ***

Comment 9 Olivier Fourdan 2017-03-10 08:20:21 UTC
*** Bug 1430894 has been marked as a duplicate of this bug. ***

Comment 11 Fedora Update System 2017-03-30 15:28:19 UTC
xorg-x11-server-1.19.3-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-fae700469f

Comment 12 Fedora Update System 2017-03-31 03:22:45 UTC
xorg-x11-server-1.19.3-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-fae700469f

Comment 13 Fedora Update System 2017-04-01 00:25:12 UTC
xorg-x11-server-1.19.3-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.