Bug 1416562 - 0cf3:e301 (Qualcomm) Bluetooth BTLE Mouse (Logitech MX Anywhere 2) Does Not Work -
Summary: 0cf3:e301 (Qualcomm) Bluetooth BTLE Mouse (Logitech MX Anywhere 2) Does Not W...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: bluez
Version: 25
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Don Zickus
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 19:58 UTC by Greg Oliver
Modified: 2017-08-21 13:15 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-21 13:15:10 UTC
Type: Bug


Attachments (Terms of Use)
dmidecode (28.92 KB, text/plain)
2017-05-23 02:46 UTC, Greg Oliver
no flags Details
lspci (41.09 KB, text/plain)
2017-05-23 02:46 UTC, Greg Oliver
no flags Details
lsusb (33.82 KB, text/plain)
2017-05-23 02:47 UTC, Greg Oliver
no flags Details

Description Greg Oliver 2017-01-25 19:58:28 UTC
Description of problem:
I have 2 laptops (identical F25 software) and the same mouse (Logitech MX Anywhere 2).  The mouse works with the Broadcom controller (Apple laptop) and not the Qualcomm controller (Dell laptop).  bluetoothctl does not see the mouse with Qualcomm although the hcidump shows identical packets with both.

Version-Release number of selected component (if applicable):
Fedora 25
bluez-libs-5.43-1.fc25.x86_64
bluez-5.43-1.fc25.x86_64
bluez-obexd-5.43-1.fc25.x86_64
bluez-cups-5.43-1.fc25.x86_64

How reproducible:
100%

Steps to Reproduce:
1.  Scan for new devices - mouse does not show up
2.
3.

Actual results:


Expected results:


Additional info:

Here is the info from the Apple computer (keep in mind Apple changes Vendor ID, but it is a Broadcom BCM20703A1

:: Apple Macbook Pro 11,5 :: - WORKS
Bus 001 Device 002: ID 05ac:8290 Apple, Inc. Bluetooth Host Controller
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.01
  bDeviceClass          239 Miscellaneous Device
  bDeviceSubClass         2
  bDeviceProtocol         1 Interface Association
  bMaxPacketSize0        64
  idVendor           0x05ac Apple, Inc.
  idProduct          0x8290 Bluetooth Host Controller
  bcdDevice            1.19
  iManufacturer           1 Broadcom Corp.
  iProduct                2 Bluetooth USB Host Controller

o hcidump
> HCI Event: LE Meta Event (0x3e) plen 38
    LE Advertising Report
      ADV_IND - Connectable undirected advertising (0)
      bdaddr CD:EE:9D:E9:B2:A2 (Random)
      Flags: 0x05
      Unknown type 0x19 with 2 bytes data
      Complete service classes: 0x1812
      Complete local name: 'MX Anywhere 2'
      RSSI: -58
> HCI Event: LE Meta Event (0x3e) plen 15
    LE Advertising Report
      SCAN_RSP - Scan Response (4)
      bdaddr CD:EE:9D:E9:B2:A2 (Random)
      TX power level: 4
      RSSI: -57

o bluetoothctl
[bluetooth]# scan on
Discovery started
[CHG] Controller A0:99:9B:0B:CD:98 Discovering: yes
[NEW] Device CD:EE:9D:E9:B2:A2 MX Anywhere 2


:: Dell XPS15 :: - NOT WORKING

Bus 001 Device 003: ID 0cf3:e301 Atheros Communications, Inc. 
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.01
  bDeviceClass          224 Wireless
  bDeviceSubClass         1 Radio Frequency
  bDeviceProtocol         1 Bluetooth
  bMaxPacketSize0        64
  idVendor           0x0cf3 Atheros Communications, Inc.
  idProduct          0xe301 

o hcidump

> HCI Event: LE Meta Event (0x3e) plen 38
    LE Advertising Report
      ADV_IND - Connectable undirected advertising (0)
      bdaddr CD:EE:9D:E9:B2:A2 (Random)
      Flags: 0x05
      Unknown type 0x19 with 2 bytes data
      Complete service classes: 0x1812
      Complete local name: 'MX Anywhere 2'
      RSSI: -49
> HCI Event: LE Meta Event (0x3e) plen 15
    LE Advertising Report
      SCAN_RSP - Scan Response (4)
      bdaddr CD:EE:9D:E9:B2:A2 (Random)
      TX power level: 4
      RSSI: -50

o bluetoothctl

[NEW] Controller 9C:B6:D0:D4:FE:74 localhost.localdomain [default]
[NEW] Device 34:88:5D:3E:03:53 Logitech K810
[NEW] Device 04:88:E2:27:4A:F3 BeatsStudio Wireless
[Logitech K810]# scan on
Discovery started
[CHG] Controller 9C:B6:D0:D4:FE:74 Discovering: yes
[NEW] Device 00:04:4B:46:E8:02 SHIELD
[NEW] Device C4:57:6E:36:D7:65 [TV]Samsung LED60

Mouse entry never makes it here.  The only log in dmesg that I get when I start a scan on this device is:
[Tue Jan 24 23:54:03 2017] hid-generic 0005:046D:B319.0008: unknown main item tag 0x0

Also note the way bluetoothctl changes the device to "[Logitech K810]# scan on" on the command line.  The apple computer does not do this.  The Logitech keyboard 810 you see is also a BTLE device, so I know the QCA driver can see those.  nbot sure where to go from here.  I have tried all Fedora kernels in F25, and like I said, both laptops have the exact software.  Not sure if I need to post here, bluez, linux-wireless to get this resolved though.  Let me know if I need to punt it elsewhere, or if more info is needed.

Thanks,

Greg Oliver

Comment 1 Greg Oliver 2017-01-25 22:46:12 UTC
I got this mouse working using hcitool - I guess this Atheros adapter driver has some different default settings for BTLE devices than the Broadcom device which is weird since my Logitech K810 keyboard is also BTLE and it showed up with no changes on my Atheros controller.

What worked to get it going was:

hcitool lescan
hcitool lewladd CD:EE:9D:E9:B2:A2
hcitool lerladd CD:EE:9D:E9:B2:A2
hcitool lecup

(I do not know if the lewladd or lerladd would fix it independently - did not try).

Then then the "scan on" by bluetoothctl immediately showed the device (as well as the gnome bluetooth app).

I'm not sure where the issue should lie (bluez or atheros), but I am sure no one should need to do this to get a mouse working :)

-Greg

Comment 2 Greg Oliver 2017-01-26 16:47:05 UTC
I would like to note that the mouse takes a long time to re-acquire after the laptop sleeps goes idle for a while.  Usually about 10 seconds.  I also do not have that issue on the Broadcom controller.

Comment 3 Peter Robinson 2017-05-16 14:19:43 UTC
Does this improve with blue 5.44? It had a number of BT-LE fixes

Comment 4 Greg Oliver 2017-05-21 03:26:11 UTC
Hi Peter -

Unfortunately not, but I am also not sure how I have 2 versions of the same apps / libs and not sure which it is using.  I still had to run lerladd to get it going.

bluez-5.42-2.fc25.x86_64
bluez-5.44-1.fc25.x86_64
bluez-cups-5.42-2.fc25.x86_64
bluez-cups-5.44-1.fc25.x86_64
bluez-libs-5.42-2.fc25.x86_64
bluez-libs-5.44-1.fc25.x86_64
bluez-obexd-5.42-2.fc25.x86_64
bluez-obexd-5.44-1.fc25.x86_64
gnome-bluetooth-3.20.0-2.fc25.x86_64
gnome-bluetooth-3.20.1-1.fc25.x86_64
gnome-bluetooth-libs-3.20.0-2.fc25.x86_64
gnome-bluetooth-libs-3.20.1-1.fc25.x86_64

Comment 5 Greg Oliver 2017-05-23 02:40:06 UTC
One other thing to note -

When I disable the wifi radio, it does not kill the bluetooth portion of the chip immediately, but if I let it sit idle or lock it - (after an undtermined amount of time), the bluetooth stops working completely until I re-enable the wifi.

Comment 6 Greg Oliver 2017-05-23 02:43:28 UTC
Oh, BTW - just in case there are other cases - this laptop is a Dell XPS 1550

	Product Name: XPS 15 9550
	Product Name: 0N7TVV

Adding hardware info as attachments..

Comment 7 Greg Oliver 2017-05-23 02:46:30 UTC
Created attachment 1281304 [details]
dmidecode

Comment 8 Greg Oliver 2017-05-23 02:46:54 UTC
Created attachment 1281305 [details]
lspci

Comment 9 Greg Oliver 2017-05-23 02:47:13 UTC
Created attachment 1281306 [details]
lsusb

Comment 10 Peter Beurle 2017-06-08 08:02:47 UTC
I have this problem with a Dell XPS 13 using the atheros WiFi / bluetooth chip. I upgraded the firmware to get the wireless stable per this thread http://en.community.dell.com/techcenter/os-applications/f/4613/t/20002634 which ahead of the standard firmware.

bluez just doesn't see the mouse on a scan but hcitool does.

Comment 11 Peter Beurle 2017-08-21 10:33:12 UTC
This is working now in F26, fixed? Not sure when it started to work.

Comment 12 Peter Robinson 2017-08-21 13:15:10 UTC
I suspect 5.46 probably did as there was a bunch of LE fixes in there


Note You need to log in before you can comment on or make changes to this bug.