Bug 1416566 - Permission denied error seen during RPM upgrade
Summary: Permission denied error seen during RPM upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kmod
Version: 7.2
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Yauheni Kaliuta
QA Contact: Ziqian SUN (Zamir)
URL:
Whiteboard:
Depends On:
Blocks: 1446211 1394638 1404314
TreeView+ depends on / blocked
 
Reported: 2017-01-25 20:20 UTC by Sarang Radke
Modified: 2020-03-05 07:05 UTC (History)
6 users (show)

Fixed In Version: 20-12.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 15:03:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
OLD RPM (4.13 MB, application/x-rpm)
2017-01-25 20:20 UTC, Sarang Radke
no flags Details
NEW RPM (4.13 MB, application/x-rpm)
2017-01-25 20:21 UTC, Sarang Radke
no flags Details
SRC RPM (2.75 MB, application/x-rpm)
2017-01-25 20:21 UTC, Sarang Radke
no flags Details
SPEC file (8.09 KB, text/plain)
2017-01-25 20:22 UTC, Sarang Radke
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1848 0 normal SHIPPED_LIVE kmod bug fix and enhancement update 2017-08-01 17:49:39 UTC

Description Sarang Radke 2017-01-25 20:20:12 UTC
Description of problem:
1. General RPM installation goes fine.

2. If we try to upgrade the RPM to newer version, following error is thrown on screen.
/sbin/weak-modules: line 174: /tmp/weak-modules.r3srrj/old_initramfs/./usr/lib/modules/3.10.0-327.el7.x86_64/extra/netxtreme2/bnx2.ko: Permission denied

3. However, installation is successful.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RPM with old version
2. Upgrade RPM to newer version
3. Observe the error

Actual results:
Error seen on screen.

Expected results:
Error should not be seen.


Additional info:
Attached: old RPM, new RPM, SRC RPM, SPEC file

Comment 1 Sarang Radke 2017-01-25 20:20:43 UTC
Created attachment 1244398 [details]
OLD RPM

Comment 2 Sarang Radke 2017-01-25 20:21:23 UTC
Created attachment 1244400 [details]
NEW RPM

Comment 3 Sarang Radke 2017-01-25 20:21:58 UTC
Created attachment 1244401 [details]
SRC RPM

Comment 4 Sarang Radke 2017-01-25 20:22:19 UTC
Created attachment 1244402 [details]
SPEC file

Comment 6 Panu Matilainen 2017-02-09 13:55:49 UTC
The error does not come from rpm but /sbin/weak-modules script. Whether it's a bug in there I have no idea, but reassigning to kmod which should be closer to the mark at least.

Comment 10 Chad Dupuis (Cavium) 2017-04-03 19:07:49 UTC
Was a fix for this made?  If so, what version?

Comment 12 errata-xmlrpc 2017-08-01 15:03:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1848


Note You need to log in before you can comment on or make changes to this bug.