Bug 141658 - SMP kernel won't boot on Promise SATA controllers
SMP kernel won't boot on Promise SATA controllers
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-02 13:57 EST by Robin Bowes
Modified: 2015-01-04 17:13 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-24 01:22:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from lspci (956 bytes, text/plain)
2004-12-02 18:18 EST, Robin Bowes
no flags Details
Output from sfdisk -l (2.38 KB, text/plain)
2004-12-02 18:22 EST, Robin Bowes
no flags Details
Output from mdadm --detail --scan (521 bytes, text/plain)
2004-12-02 18:25 EST, Robin Bowes
no flags Details
kernel build parameters (11.58 KB, application/x-gzip-compressed)
2004-12-14 13:05 EST, Bernd Foerster
no flags Details

  None (edit)
Description Robin Bowes 2004-12-02 13:57:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
I was running Fedora Core 2 and upgraded to Fedora Core 3.

The upgrade appeared to go fine but when I rebooted I got a kernel
panic with the following message:

Loading ext3.ko module
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
Creating root device
Mounting root filesystem
EXT3-fs: unable to read superblock
mount: error 22 mounting ext3
mount: error 2 mounting none
Switching to new root
switchroot: mount failed: 22
umount /initrd/dev failed: 2
Kernel panic - not syncing: Attempted to kill init!

Booting to rescue mode and running yum update installed all the latest
packages including kernel-2.6.9-1.681_FC3smp but I still got the same
error.

I then installed kernel-2.6.9-1.681_FC3 (i.e. single processor kernel)
and the system booted up fine.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.9-1.667 and kernel-smp-2.6.9-1.681_FC3

How reproducible:
Didn't try

Steps to Reproduce:
I've not tried this but I've read other reports that suggest that this
problem also exists with a fresh install

Additional info:
Comment 1 Dave Jones 2004-12-02 14:12:55 EST
it didnt detect your raid arrays. Can you tell me what types of disk /
controller you have ?
Comment 2 Robin Bowes 2004-12-02 18:18:48 EST
Created attachment 107794 [details]
Output from lspci
Comment 3 Robin Bowes 2004-12-02 18:22:25 EST
Created attachment 107795 [details]
Output from sfdisk -l
Comment 4 Robin Bowes 2004-12-02 18:24:10 EST
I have 5 x Maxtor Maxline II 250GB SATA drivers connected to 2 x Promise SAT150
TX4 controllers (3 on one controller, 2 on the other).
Comment 5 Robin Bowes 2004-12-02 18:25:15 EST
Created attachment 107796 [details]
Output from mdadm --detail --scan
Comment 6 Robin Bowes 2004-12-03 13:14:35 EST
I've had a look at the contents of the initrd for kernel-2.6.9-1.681_FC3 vs.
kernel-2.6.9-1.681_FC3smp.

kernel-2.6.9-1.681_FC3smp is missing the following modules:

Only in initrd-2.6.9-1.681_FC3/lib: sata_promise.ko
Only in initrd-2.6.9-1.681_FC3/lib: scsi_mod.ko
Only in initrd-2.6.9-1.681_FC3/lib: sd_mod.ko

Also, the following lines are missing in init:

-echo "Loading scsi_mod.ko module"
-insmod /lib/scsi_mod.ko
-echo "Loading sd_mod.ko module"
-insmod /lib/sd_mod.ko
-echo "Loading libata.ko module"
-insmod /lib/libata.ko
-echo "Loading sata_promise.ko module"
-insmod /lib/sata_promise.ko

That explains why kernel-2.6.9-1.681_FC3smp won't boot on my system.

Looking in the initrd of kernel-2.6.9-1.667_FC3smp I can see the same differences.

So, looks like mystery solved.

When can you release a new kernel? :)
Comment 7 Bernd Foerster 2004-12-07 20:21:33 EST
Installed Fedora core 3 on a brand new
Dell Poweredge 1800 dual xeon, no raid, bootdrive is /dev/sda1

Similar error message as original post (just without the RAID things)

SMP kernel didnt work, 1CPU kernel works OK
original install kernel where 2.6.9-1.667
upgraded both 1CPU and SMP to 2.6.9-1.681, same problem, no change

setting boot parameters in /boot/grub/grub.conf solved the problem
original: kernel=/boot/vmlinuz-2.6.9-1.681_FC3smp ro root=LABEL=/ 
rhgb quiet
changed:  kernel=/boot/vmlinuz-2.6.9-1.681_FC3smp ro root=/dev/sda1 
rhgb

seems that the SMP kernel has to get some explicit help where to find 
the root mount point. Providing this information everything seems to 
work OK (just started hardcore stability testing)

if the initrd thing from post#6 also is an issue u may try mkinitrd.
Didnt really try that but just as a guess:
mkinitrd /boot/<yourSMPkernel.img> <yourSMPkernel> --
fstab=/etc/fstab --preload=scsi_mod --preload=sd_mod --
preload=libdata --preload=ata_piix --preload=jbd --preload=ext3

BE CAREFULL WITH THAT AXE EUGENE (untested):
to overwrite <yourSMPkernel.img> use parameter -f 
oh..., and first backup <yourSMPkernel.img>

to determine what modules have to preloaded u may boot 1CPU and look 
with lsmod




Comment 8 Bernd Foerster 2004-12-08 19:48:28 EST
additional info on post #7

seems to be that mkinitrd also is important and should be done before 
editing grub, however result is not reproducible, boot process 
intermitently fails

kernel-smp-2.6.8-1.521.x86_64.rpm from FC2 update workx under FC3
(SElinux disabled)

Comment 9 Bernd Foerster 2004-12-14 13:05:03 EST
Created attachment 108542 [details]
kernel build parameters
Comment 10 Bernd Foerster 2004-12-14 13:07:57 EST
compiled kernel from source:
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/SRPM
S/kernel-2.6.9-1.681_FC3.src.rpm

no patches applied yet
SCSI disc support and EXT3 support built into kernel (not as module)
see config.gz above

workx great
Comment 11 Dave Jones 2005-02-12 23:30:59 EST
Robin, any better with the latest errata kernels ?
Comment 12 Robin Bowes 2005-02-14 07:12:13 EST
Dave,

It appears that the problem was that the promise module was not getting copied
to the initrd image. I guess this was a problem with mkinitrd rather than the
kernel.

Anyway, all is working fine now.

Thanks,

R.
Comment 13 Matthew Miller 2005-02-14 10:08:49 EST
For what it's worth, I'm seeing problems with incorrectly-created initrds *all
the time*. Rerunning mkinitrd manually almost always works. On FC2, bug #144441
is part of the problem, but doesn't apply to FC3, so it's something else there. 

Note You need to log in before you can comment on or make changes to this bug.