Bug 1416628 - Error generating Chargeback reports for SCVMM when storage fields are added to report
Summary: Error generating Chargeback reports for SCVMM when storage fields are added t...
Keywords:
Status: CLOSED DUPLICATE of bug 1416001
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.7.1
Assignee: Gregg Tanzillo
QA Contact: Nandini Chandra
URL:
Whiteboard: chargeback:scvmm
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-26 05:41 UTC by Nandini Chandra
Modified: 2017-02-02 04:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-26 15:58:11 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Description Nandini Chandra 2017-01-26 05:41:26 UTC
Description of problem:
-----------------------
I'm unable to generate Chargeback reports for SCVMM when the following fields are added to the report.I can successfully generate Chargeback reports when other fields are added to the report.


Storage Allocated , Storage Allocated Cost

Here's a snippet from evm.log:

[----] E, [2017-01-19T14:57:46.543893 #2945:73f140] ERROR -- : [FloatDomainError]: Infinity Method:[rescue in _async_generate_table]
[----] E, [2017-01-19T14:57:46.544229 #2945:73f140] ERROR -- : /var/www/miq/vmdb/app/models/chargeback_rate_detail.rb:62:in to_r' /var/www/miq/vmdb/app/models/chargeback_rate_detail.rb:62:in<='
/var/www/miq/vmdb/app/models/chargeback_rate_detail.rb:62:in block in find_rate' /opt/rubies/ruby-2.3.1/lib/ruby/gems/2.3.0/gems/activerecord-5.0.1/lib/active_record/associations/collection_association.rb:92:inblock in select'
/opt/rubies/ruby-2.3.1/lib/ruby/gems/2.3.0/gems/activerecord-5.0.1/lib/active_record/associations/collection_association.rb:92:in select' /opt/rubies/ruby-2.3.1/lib/ruby/gems/2.3.0/gems/activerecord-5.0.1/lib/active_record/associations/collection_association.rb:92:ineach'
/opt/rubies/ruby-2.3.1/lib/ruby/gems/2.3.0/gems/activerecord-5.0.1/lib/active_record/associations/collection_association.rb:92:in select' /opt/rubies/ruby-2.3.1/lib/ruby/gems/2.3.0/gems/activerecord-5.0.1/lib/active_record/associations/collection_proxy.rb:110:inselect'
/var/www/miq/vmdb/app/models/chargeback_rate_detail.rb:60:in find_rate' /var/www/miq/vmdb/app/models/chargeback_rate_detail.rb:84:inhourly_cost'
/var/www/miq/vmdb/app/models/chargeback_rate_detail.rb:236:in metric_and_cost_by' /var/www/miq/vmdb/app/models/chargeback_rate_detail.rb:26:incharge'
/var/www/miq/vmdb/app/models/chargeback.rb:71:in block (2 levels) in calculate_costs' /var/www/miq/vmdb/app/models/chargeback.rb:70:ineach'
/var/www/miq/vmdb/app/models/chargeback.rb:70:in block in calculate_costs' /var/www/miq/vmdb/app/models/chargeback.rb:69:ineach'
/var/www/miq/vmdb/app/models/chargeback.rb:69:in calculate_costs' /var/www/miq/vmdb/app/models/chargeback.rb:29:inblock in build_results_for_report_chargeback'
/var/www/miq/vmdb/app/models/chargeback/consumption_history.rb:15:in block (2 levels) in for_report' /opt/rubies/ruby-2.3.1/lib/ruby/gems/2.3.0/gems/activerecord-5.0.1/lib/active_record/relation/delegation.rb:38:ineach'
/opt/rubies/ruby-2.3.1/lib/ruby/gems/2.3.0/gems/activerecord-5.0.1/lib/active_record/relation/delegation.rb:38:in each' /var/www/miq/vmdb/app/models/chargeback/consumption_history.rb:14:inblock in for_report'
/var/www/miq/vmdb/app/models/chargeback/consumption_history.rb:13:in each' /var/www/miq/vmdb/app/models/chargeback/consumption_history.rb:13:ineach_cons'
/var/www/miq/vmdb/app/models/chargeback/consumption_history.rb:13:in for_report' /var/www/miq/vmdb/app/models/chargeback.rb:19:inbuild_results_for_report_chargeback'
/var/www/miq/vmdb/app/models/chargeback_vm.rb:45:in build_results_for_report_ChargebackVm' /var/www/miq/vmdb/app/models/miq_report/generator.rb:193:in_generate_table'
/var/www/miq/vmdb/app/models/miq_report/generator.rb:167:in block in generate_table' /var/www/miq/vmdb/app/models/user.rb:241:inwith_user'
/var/www/miq/vmdb/app/models/miq_report/generator.rb:167:in generate_table' /var/www/miq/vmdb/app/models/miq_report/generator/async.rb:96:in_async_generate_table'
/var/www/miq/vmdb/app/models/miq_queue.rb:347:in block in deliver' /opt/rubies/ruby-


Version-Release number of selected component (if applicable):
--------------------------------------------------------------
5.7.1


How reproducible:
-----------------
Always


Steps to Reproduce:
-------------------
1.Manage a provider.Enable C&U for the provider.
2.Assign Compute rates and generate a Chargeback report.


Actual results:
---------------
Error generating Chargeback reports.


Expected results:
-----------------
No errors while generating Chargeback reports.


Additional info:
-----------------
https://github.com/ManageIQ/manageiq/issues/13591

Comment 3 Šimon Lukašík 2017-01-26 15:58:11 UTC
Indeed.

*** This bug has been marked as a duplicate of bug 1416001 ***


Note You need to log in before you can comment on or make changes to this bug.