Bug 1416639 - Reject NFS storage configurations for registry, logging, metrics
Summary: Reject NFS storage configurations for registry, logging, metrics
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 3.10.0
Assignee: Michael Gugino
QA Contact: Gaoyun Pei
URL:
Whiteboard:
: 1538298 1538867 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-26 07:13 UTC by Marko Myllynen
Modified: 2018-07-30 19:09 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-30 19:08:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:09:27 UTC
Red Hat Bugzilla 1570284 None MODIFIED [DOCS] Reject NFS storage configurations for registry, logging, metrics 2019-09-12 11:05:37 UTC

Internal Links: 1570284

Description Marko Myllynen 2017-01-26 07:13:11 UTC
Description of problem:
Scaled registry means having >= 2 registry replicas.

Scaled registry requires a storage which provides read-after-write consistency.

NFS does not provide read-after-write consistency.

Thus the following configuration is invalid:

openshift_hosted_registry_replicas=2
openshift_hosted_registry_storage_kind=nfs
openshift_hosted_registry_storage_access_modes=['ReadWriteMany']

The installer should not accept and setup this kind of configuration (or any other invalid configuration).

Comment 2 Marko Myllynen 2017-01-26 07:24:12 UTC
Another example would be ElasticSearch / NFS, see https://docs.openshift.com/container-platform/3.4/install_config/aggregate_logging.html#aggregated-elasticsearch.

Comment 10 Michael Gugino 2018-04-09 18:44:42 UTC
PR Created: https://github.com/openshift/openshift-ansible/pull/7867

Comment 11 Michael Gugino 2018-04-11 18:47:02 UTC
Backport to 3.9 created: https://github.com/openshift/openshift-ansible/pull/7920

Comment 12 Scott Dodson 2018-04-19 14:26:17 UTC
*** Bug 1538298 has been marked as a duplicate of this bug. ***

Comment 15 daniel 2018-04-21 14:41:08 UTC
thanks, Michael!

created 

https://bugzilla.redhat.com/show_bug.cgi?id=1570284

for docs

Comment 22 Scott Dodson 2018-05-02 18:27:48 UTC
*** Bug 1538867 has been marked as a duplicate of this bug. ***

Comment 25 Gaoyun Pei 2018-05-17 08:03:25 UTC
Verify this bug with openshift-ansible-3.10.0-0.47.0.git.0.c018c8f.el7.noarch.rpm

Set registry or prometheus using nfs storage in ansible inventory, then installer will fail in variable sanity check.

openshift_hosted_registry_storage_kind=nfs 

TASK [Run variable sanity checks] **********************************************
Wednesday 16 May 2018  22:54:02 -0400 (0:00:00.863)       0:00:24.573 ********* 
fatal: [ec2-54-173-75-179.compute-1.amazonaws.com]: FAILED! => {"failed": true, "msg": "last_checked_host: ec2-54-173-75-179.compute-1.amazonaws.com, last_checked_var: openshift_hosted_registry_storage_kind;nfs is an unsupported type for openshift_hosted_registry_storage_kind. openshift_enable_unsupported_configurations=True mustbe specified to continue with this configuration."}


openshift_prometheus_storage_kind=nfs

TASK [Run variable sanity checks] **********************************************
Wednesday 16 May 2018  23:18:41 -0400 (0:00:00.828)       0:00:22.202 ********* 
fatal: [ec2-18-206-191-96.compute-1.amazonaws.com]: FAILED! => {"failed": true, "msg": "last_checked_host: ec2-18-206-191-96.compute-1.amazonaws.com, last_checked_var: openshift_prometheus_storage_kind;nfs is an unsupported type for openshift_prometheus_storage_kind. openshift_enable_unsupported_configurations=True mustbe specified to continue with this configuration."}


With openshift_enable_unsupported_configurations=true set in addition, the installation with NFS storage used could continue.

Comment 27 Eric Rich 2018-07-19 14:09:09 UTC
We need to connect https://bugzilla.redhat.com/show_bug.cgi?id=1589137 to this thread.

Comment 29 errata-xmlrpc 2018-07-30 19:08:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.