Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1416649 - yum update might not be enough to get the same package versions as on the binary DVD
Summary: yum update might not be enough to get the same package versions as on the bin...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Docs Install Guide
Version: 6.2.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: Julie
QA Contact: Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-26 08:12 UTC by Evgeni Golov
Modified: 2019-09-26 16:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-18 23:28:17 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Evgeni Golov 2017-01-26 08:12:30 UTC
Document URL: 
https://access.redhat.com/documentation/en/red-hat-satellite/6.2/paged/installation-guide/chapter-3-installing-satellite-server

Section Number and Name: 
3.2.3. Installing from the Offline Repositories

Describe the issue:
The guide currently suggests the user:

Ensure the base system is up to date with the Binary DVD image.
# yum update

However, the binary DVD only contains the GA bits of the release and the user might have updated packages by other means between installing the machine and installing Satellite (even if they should not).

If they did updates, this might lead to dependency errors when installing Satellite, which will try to fetch base packages from the RHEL ISO and these conflict with other already installed packages. Example yum error:

Error: Package: libkadm5-1.14.1-26.el7.x86_64 (rhel7)
           Requires: krb5-libs(x86-64) = 1.14.1-26.el7
           Installed: krb5-libs-1.14.1-27.el7_3.x86_64 (@rhel-7-server-rpms)
               krb5-libs(x86-64) = 1.14.1-27.el7_3
           Available: krb5-libs-1.14.1-26.el7.x86_64 (rhel7)
               krb5-libs(x86-64) = 1.14.1-26.el7
Error while executing command: 'yum install -y satellite'

To fix such a situation, the user might execute "yum distribution-synchronization" which will downgrade packages to the versions provided by the repos (which come from the ISO).

Suggestions for improvement:
Hint the user "yum distribution-synchronization" might be useful, but don't let them execute it by default.

Additional information:


Note You need to log in before you can comment on or make changes to this bug.