Bug 1416686 - installation failed on GCE with cloudprovider enabled
Summary: installation failed on GCE with cloudprovider enabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Jason DeTiberus
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-26 09:14 UTC by Weihua Meng
Modified: 2017-07-24 14:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-04-11 21:15:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0903 normal SHIPPED_LIVE OpenShift Container Platform atomic-openshift-utils bug fix and enhancement 2017-04-12 22:45:42 UTC

Description Weihua Meng 2017-01-26 09:14:16 UTC
Description of problem:
Installation failed on GCE with cloudprovider enabled

Version-Release number of selected component (if applicable):
openshift-ansible-3.5.2-1

How reproducible:
Always

Steps to Reproduce:
1.install OpenShift v3.5 cluster on GCE with cloudprovider enabled

Actual results:
Failed.
TASK [openshift_cloud_provider : Set cloud provider facts] *********************
Thursday 26 January 2017  04:17:27 +0000 (0:00:00.689)       0:04:11.398 ****** 

An exception occurred during task execution. To see the full traceback, use -vvv. The error was: KeyError: 'hostname'
fatal: [qe-wmeng353-oa351master-nfs-1.0126-to7.qe.rhcloud.com]: FAILED! => {"changed": false, "failed": true, "module_stderr": "Traceback (most recent call last):\n  File \"/tmp/ansible_1znXpn/ansible_module_openshift_facts.py\", line 2476, in <module>\n    main()\n  File \"/tmp/ansible_1znXpn/ansible_module_openshift_facts.py\", line 2463, in main\n    protected_facts_to_overwrite)\n  File \"/tmp/ansible_1znXpn/ansible_module_openshift_facts.py\", line 1920, in __init__\n    protected_facts_to_overwrite)\n  File \"/tmp/ansible_1znXpn/ansible_module_openshift_facts.py\", line 1990, in generate_facts\n    facts = set_nodename(facts)\n  File \"/tmp/ansible_1znXpn/ansible_module_openshift_facts.py\", line 1036, in set_nodename\n    facts['node']['nodename'] = '.'.split(facts['provider']['metadata']['hostname'])[0]\nKeyError: 'hostname'\n", "module_stdout": "", "msg": "MODULE FAILURE"}

Expected results:
Install success

Additional info:
likely caused by this:
https://github.com/openshift/openshift-ansible/commit/151e25cc0ff12dd046efcdd61fa5a1ad21a96ac5#diff-8c83287a125220bc46f58c79f26c6670

Comment 1 Johnny Liu 2017-02-06 08:45:17 UTC
Seem like this bug is already fixed in openshift-ansible-3.5.3-1.git.0.80c2436.el7.noarch.

Comment 2 Xiaoli Tian 2017-02-07 02:30:14 UTC
Per comment 1, this is already fixed, feel free to move it to ON_QA if no more extra fix is needed.

Comment 4 Weihua Meng 2017-02-09 02:56:40 UTC
Verified as fixed on
openshift-ansible-3.5.5-1.git.0.3ae2138.el7.noarch.rpm
Finished: SUCCESS


Note You need to log in before you can comment on or make changes to this bug.