Bug 141673 - Recent update of cyrus-imapd changes /etc/imapd.conf
Recent update of cyrus-imapd changes /etc/imapd.conf
Status: CLOSED DUPLICATE of bug 141470
Product: Fedora
Classification: Fedora
Component: cyrus-imapd (Show other bugs)
2
All Linux
medium Severity high
: ---
: ---
Assigned To: John Dennis
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-02 15:29 EST by Fritz Elfert
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fritz Elfert 2004-12-02 15:29:17 EST
Description of problem:
The file /etc/imapd.conf is somehow wrongly tagged in the recent
update rpm. When performing unattended nightly yum updates,
instead of saving the new /etc/imapd.conf in /etc/imapd.conf.rpmnew,
it saves the old file in /etc/imapd.conf.rpmsave and creates a new
/etc/imapd.conf, rendering customized installations unusable (e.g:
here, we use auxprop authentication, unixhierarchysep and more auth
methods than just PLAIN). Thus, next morning, nobody could access
their imap accounts.

Version-Release number of selected component (if applicable):
2.2.10-1.fc2

How reproducible:
always

Steps to Reproduce:
1. Customize /etc/imapd.conf
2. Update cyrus-imapd to 2.2.10-1.fc2
3.
  
Actual results:
Previous customizations are not effective anymore. Which could
lead to render imapd services unusable, until someone restores
/etc/imapd.conf manually

Expected results:
New config file should be stored in /etc/imapd.conf.rpmnew

Additional info:
Comment 1 John Dennis 2004-12-02 16:30:39 EST
Thank you for your bug report, this was brought to our attention
yesterday in bug #141470, so I'm marking this bug as a duplicate of
that. The fix has been applied to the spec files. It's not clear to me
that pushing an update for this makes sense, if updates are applied in
 sequence as would be typical an update with the fix won't save them,
I will evaluate the merit of that, as opposed to just having the
config file fix appear when another issue forces an update. 

*** This bug has been marked as a duplicate of 141470 ***
Comment 2 John Dennis 2004-12-02 18:39:10 EST
FYI, new versions of cyrus-imapd have been built that set
    /etc/imapd.conf
    /etc/cyrus.conf
to be "noreplace". Packages are waiting for signature and push.
Comment 3 Red Hat Bugzilla 2006-02-21 14:07:28 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.