Bug 141676 - Smarty template engine do not work anymore
Summary: Smarty template engine do not work anymore
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted   
(Show other bugs)
Version: 3
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords: SELinux
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-02 20:49 UTC by Daniel Liscia
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-03 19:18:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Liscia 2004-12-02 20:49:04 UTC
Description of problem:

PHP applications that use the Smarty template engine ceased to work.
My php applications work perfectly in Fedora Core 2, not in
Fedora Core 3 with exactly the identical setup.
Don't know whether it is a Apache or php problem. Don't think
it's my fault.

Version-Release number of selected component (if applicable):
Fedora Core 3

How reproducible:
reproducible

Steps to Reproduce:
setup a php application that uses  the Smarty template
engine (all versions). I even tried the demo script that
comes with the Smarty documentation

Actual results:
php is unable to save the compiled scripts in compile_dir = /templates_c/
I set correctly the write access, I used the identical
configuration files of Fedora Core 2 (php.ini etc...)

Expected results:


Additional info:

I reinstalles Fedora Core 2 in my server and instantly
everything worked again as usual! 
Lost two days work

Comment 1 Joe Orton 2004-12-02 21:28:43 UTC
This is likely to be due to SELinux, such issues are relatively simple
to resolve or work around; please give the output of:

# grep audit /var/log/messages

as root; see also the SELinux/Apache documentation at:
http://fedora.redhat.com/docs/selinux-apache-fc3/

Comment 2 Daniel Liscia 2004-12-03 08:01:19 UTC
Sorry I cannot give you the grep ouput you requested because
I went back to Fedora C2 as soon as I realized I could not 
fix the problem of Smarty not working myself.

Somebody, that has a spare PC with FC3 on it should try the
demo that comes with the Smarty template engine and tell me
the results.

Best regards

Daniel S. Liscia
danyliscia@libero.it

Comment 3 Daniel Walsh 2004-12-03 19:18:30 UTC
Yes this is not a bug.  You have one of three options.

1 Label the smarty directory properly to get it to work with SELinux
2 Turn off apache protection for selinux
3 Turn off selinux.

http://fedora.redhat.com/docs/selinux-apache-fc3/
Has the best desctiption on how to handle this.

Dan


Note You need to log in before you can comment on or make changes to this bug.