Bug 1416775 - Inconsistent infra openstack provider labelling hosts / nodes
Summary: Inconsistent infra openstack provider labelling hosts / nodes
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Marek Aufart
QA Contact: Omri Hochman
URL:
Whiteboard: openstack:infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-26 11:27 UTC by Ronnie Rasouli
Modified: 2018-10-02 14:32 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-02 14:29:29 UTC
Category: Bug
Cloudforms Team: Openstack
Target Upstream Version:


Attachments (Terms of Use)
Hosts appears before provider refresh (105.18 KB, image/png)
2017-01-29 06:50 UTC, Ronnie Rasouli
no flags Details
Nodes appears after refresh (110.87 KB, image/png)
2017-01-29 06:51 UTC, Ronnie Rasouli
no flags Details

Description Ronnie Rasouli 2017-01-26 11:27:08 UTC
Description of problem:

There is an inconsistency for an openstack provider hosts, when the openstack infra provider successfully refreshed, the infra provider details changes from hosts to nodes. 

We should have an consistent label for openstack infra provider - Nodes

Version-Release number of selected component (if applicable):
Any

How reproducible:
100%

Steps to Reproduce:
1. add openstack infra provider
2. go to host details

Actual results:

under relationships table labelled as 'Hosts' appear

After refresh is done label change to Nides

Expected results:


Additional info:

This inconsistency could harm automation test results

Comment 4 Ronnie Rasouli 2017-01-29 06:50:32 UTC
Created attachment 1245504 [details]
Hosts appears before provider refresh

Comment 5 Ronnie Rasouli 2017-01-29 06:51:32 UTC
Created attachment 1245505 [details]
Nodes appears after refresh

Comment 7 Harpreet Kataria 2017-02-07 21:05:11 UTC
Ronnie, 

By design when openstack hosts do not exist under a selected infrastructure provider title is displayed as "Hosts", when both open/non-openstack hosts exist title is changed to Hosts/Nodes and when there are only openstack Hosts under a provider title is displayed as "Nodes"

Is there way t handle this in automate tests. Let me know if you have further questions.

Thanks,
~Harpreet

Comment 12 Josh Carter 2018-10-02 14:29:29 UTC
Dear customer, 

The CloudForms team is reviewing the current CloudForms Bug(defect) backlog in order to target engineering efforts. We are closing any bugs for versions that no longer have an active errata stream or that have hit their age limit. We are committing to better management of the backlog as we move forward. If you have an bug that you are still able to reproduce on a current version of CloudForms please open a new bug. 

If you have any concerns about this, please let us know.

Thanks and regards!

Comment 13 Josh Carter 2018-10-02 14:32:12 UTC
Dear customer, 

The CloudForms team is reviewing the current CloudForms Bug(defect) backlog in order to target engineering efforts. We are closing any bugs for versions that no longer have an active errata stream or that have hit their age limit. We are committing to better management of the backlog as we move forward. If you have an bug that you are still able to reproduce on a current version of CloudForms please open a new bug. 

If you have any concerns about this, please let us know.

Thanks and regards!


Note You need to log in before you can comment on or make changes to this bug.