Bug 1416781 - puppet-master requesting invalid selinux contexts
Summary: puppet-master requesting invalid selinux contexts
Keywords:
Status: CLOSED DUPLICATE of bug 1202924
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: SELinux
Version: 6.2.7
Hardware: All
OS: Linux
medium
medium
Target Milestone: Unspecified
Assignee: Lukas Zapletal
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-26 11:49 UTC by Ben
Modified: 2017-01-31 15:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-31 15:15:58 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ben 2017-01-26 11:49:02 UTC
Description of problem:

Just a sample of some of the /var/log/messages scroll I get occasionally from puppet-master.  Probably an issue with selinux rather than puppet.

Jan 26 11:41:11 satellite1 puppet-master[62367]: /etc/selinux/targeted/contexts/files/file_contexts:  invalid context system_u:object_r:puppet_etc_t:s0
Jan 26 11:41:11 satellite1 puppet-master[62367]: /etc/selinux/targeted/contexts/files/file_contexts:  invalid context system_u:object_r:puppet_etc_t:s0
Jan 26 11:41:11 satellite1 puppet-master[62367]: /etc/selinux/targeted/contexts/files/file_contexts:  invalid context system_u:object_r:puppet_etc_t:s0
Jan 26 11:41:11 satellite1 puppet-master[62367]: /etc/selinux/targeted/contexts/files/file_contexts:  invalid context system_u:object_r:puppet_etc_t:s0
Jan 26 11:41:11 satellite1 puppet-master[62367]: /etc/selinux/targeted/contexts/files/file_contexts:  invalid context system_u:object_r:puppet_var_lib_t:s0
Jan 26 11:41:11 satellite1 puppet-master[62367]: /etc/selinux/targeted/contexts/files/file_contexts:  invalid context system_u:object_r:puppet_var_lib_t:s0
Jan 26 11:41:11 satellite1 puppet-master[62367]: /etc/selinux/targeted/contexts/files/file_contexts:  invalid context system_u:object_r:puppet_var_lib_t:s0
Jan 26 11:41:11 satellite1 puppet-master[62367]: /etc/selinux/targeted/contexts/files/file_contexts:  invalid context system_u:object_r:puppet_var_lib_t:s0
Jan 26 11:41:11 satellite1 puppet-master[62367]: /etc/selinux/targeted/contexts/files/file_contexts:  invalid context system_u:object_r:puppet_log_t:s0
Jan 26 11:41:11 satellite1 puppet-master[62367]: /etc/selinux/targeted/contexts/files/file_contexts:  invalid context system_u:object_r:puppet_log_t:s0
Jan 26 11:41:11 satellite1 puppet-master[62367]: /etc/selinux/targeted/contexts/files/file_contexts:  invalid context system_u:object_r:puppet_log_t:s0
Jan 26 11:41:11 satellite1 puppet-master[62367]: /etc/selinux/targeted/contexts/files/file_contexts:  invalid context system_u:object_r:puppet_log_t:s0
Jan 26 11:41:11 satellite1 puppet-master[62367]: /etc/selinux/targeted/contexts/files/file_contexts:  invalid context system_u:object_r:puppet_var_lib_t:s0
Jan 26 11:41:11 satellite1 puppet-master[62367]: /etc/selinux/targeted/contexts/files/file_contexts:  invalid context system_u:object_r:puppet_var_lib_t:s0
Jan 26 11:41:11 satellite1 puppet-master[62367]: /etc/selinux/targeted/contexts/files/file_contexts:  invalid context system_u:object_r:puppet_var_lib_t:s0
Jan 26 11:41:11 satellite1 puppet-master[62367]: /etc/selinux/targeted/contexts/files/file_contexts:  invalid context system_u:object_r:puppet_var_lib_t:s0
Jan 26 11:41:11 satellite1 puppet-master[62367]: /etc/selinux/targeted/contexts/files/file_contexts:  invalid context system_u:object_r:puppet_var_run_t:s0
Jan 26 11:41:11 satellite1 puppet-master[62367]: /etc/selinux/targeted/contexts/files/file_contexts:  invalid context system_u:object_r:puppet_var_run_t:s0
Jan 26 11:41:11 satellite1 puppet-master[62367]: /etc/selinux/targeted/contexts/files/file_contexts:  invalid context system_u:object_r:puppet_var_run_t:s0
Jan 26 11:41:11 satellite1 puppet-master[62367]: /etc/selinux/targeted/contexts/files/file_contexts:  invalid context system_u:object_r:puppet_var_run_t:s0
Jan 26 11:41:11 satellite1 puppet-master[62367]: /etc/selinux/targeted/contexts/files/file_contexts:  invalid context system_u:object_r:puppet_var_lib_t:s0

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Ben 2017-01-26 11:52:55 UTC
Apologies, hit "Save" too soon.  These showed up both before and after upgrade from 6.2.6 to 6.2.7.  I can't see what I might be doing to trigger them.  Sometimes they appear in the very early hours of the morning.  I don't (as far as I can tell) actively use any part of the puppet infrastructure within Satellite (but I'm sure some is used behind the scenes for me).

Comment 3 Lukas Zapletal 2017-01-31 15:15:58 UTC
Hello Ben, thanks for the report. We are tracking this as

https://bugzilla.redhat.com/show_bug.cgi?id=1202924

but I am unable to reproduce the behavior, if you can help to narrow down the moment when this happens, this would be big help. Thanks.

*** This bug has been marked as a duplicate of bug 1202924 ***


Note You need to log in before you can comment on or make changes to this bug.