Bug 1416816 - Unable to alt-tab window switch on any X screen other than primary X screen 0
Summary: Unable to alt-tab window switch on any X screen other than primary X screen 0
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kde-workspace
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Jan Grulich
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1420851
TreeView+ depends on / blocked
 
Reported: 2017-01-26 14:34 UTC by Deepu K S
Modified: 2020-12-14 08:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-14 11:31:58 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Deepu K S 2017-01-26 14:34:00 UTC
Description of problem:
In case of multiple monitors, Alt-Tab (to switch application windows) has no effect on secondary monitors. 
Alt-tab on the primary xscreen 0 works as intended. Alt-tab on xscreen 1 through 3 has no effect.

Using a single X screen across all monitors allows alt-tab to work, but individual X screens per monitor is required for business use.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux 7.3
kde-workspace-4.11.19-8.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Login to KDE session on a multi-monitor setup.
2. Open any application on screen 1 and then on screen 2.
3. Try to switch windows by Alt-tab.

Actual results:
Alt-Tab works on screen 0 (primary)
Alt-Tab switch doesn't work on secondary screens.

Expected results:
Alt-Tab switch should work on all screens.

Additional info:

Comment 2 Red Hat Bugzilla Rules Engine 2017-08-14 11:31:58 UTC
Development Management has reviewed and declined this request. You may appeal this decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.