Bug 1416817 - firewall-cmd very slow when loading large XML files
Summary: firewall-cmd very slow when loading large XML files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: firewalld
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Thomas Woerner
QA Contact: Tomas Dolezal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-26 14:35 UTC by Ole Holm Nielsen
Modified: 2017-08-01 16:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 16:22:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1934 0 normal SHIPPED_LIVE firewalld bug fix and enhancement update 2017-08-01 17:55:15 UTC

Description Ole Holm Nielsen 2017-01-26 14:35:09 UTC
Description of problem:
firewall-cmd very slow when loading large XML files

Version-Release number of selected component (if applicable):
firewalld-0.4.3.2-8.1.el7_3.noarch

How reproducible:
Always, when loading large XML files, in our case about 61.000 lines

Steps to Reproduce:
1. firewall-cmd --permanent --ipset=$IPSETNAME --add-entries-from-file=$IPSET takes 76 seconds.
2. firewall-cmd --reload takes 59 seconds. 

Actual results:
Operation takes about 1 minute or more

Expected results:
Operation should complete within 1-2 seconds

Additional info:
Large XML files seems to be the cause of the slow response.

Comment 5 Tomas Dolezal 2017-06-09 10:27:43 UTC
verified firewalld-0.4.4.4-5.el7 on x86_64

wc -l /mnt/tests/firewalld/ipset.list 
65025 /mnt/tests/firewalld/ipset.list

new:
time firewall-cmd --permanent --ipset myipset --add-entries-from-file /mnt/tests/firewalld/ipset.list 
success

real	0m1.261s
user	0m0.212s
sys	0m0.019s

time systemctl restart firewalld
real	0m0.937s
user	0m0.006s
sys	0m0.009s

old:
success
time firewall-cmd --permanent --ipset myipset --add-entries-from-file /mnt/tests/firewalld/ipset.list 
success

real	1m1.335s
user	1m0.332s
sys	0m0.018s
[root@vm-rhel7s ~]# time systemctl restart firewalld
real	0m45.240s
user	0m0.006s
sys	0m0.002s

Comment 6 errata-xmlrpc 2017-08-01 16:22:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1934


Note You need to log in before you can comment on or make changes to this bug.