Bug 1416842 - numpy too old for Gnocchi
Summary: numpy too old for Gnocchi
Keywords:
Status: CLOSED DUPLICATE of bug 1417881
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director-images
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-26 15:07 UTC by Alex Krzos
Modified: 2017-02-02 15:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-02 15:10:40 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Alex Krzos 2017-01-26 15:07:38 UTC
Description of problem:
Gnocchi requires numpy 1.9 or newer

Version-Release number of selected component (if applicable):
OSP11 Ocata
Build 2017-01-24.2

How reproducible:
Always

Steps to Reproduce:
1. Have metricd spawn workers (Set workers in the conf file, this is bzed too https://bugzilla.redhat.com/show_bug.cgi?id=1416349)
2. tail metricd.log for errors
3.

Actual results:

on overcloud nodes:

Python 2.7.5 (default, Aug  2 2016, 04:20:16) 
[GCC 4.8.5 20150623 (Red Hat 4.8.5-4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import numpy
>>> numpy.__version__
'1.7.1'



Errors:
2017-01-26 12:48:26.436 545651 ERROR gnocchi.storage._carbonara [-] Error processing new measures
2017-01-26 12:48:26.436 545651 ERROR gnocchi.storage._carbonara Traceback (most recent call last):
2017-01-26 12:48:26.436 545651 ERROR gnocchi.storage._carbonara   File "/usr/lib/python2.7/site-packages/gnocchi/storage/_carbonara.py", line 461, in process_new_measures
2017-01-26 12:48:26.436 545651 ERROR gnocchi.storage._carbonara     self._compute_and_store_timeseries(metric, measures)
2017-01-26 12:48:26.436 545651 ERROR gnocchi.storage._carbonara   File "/usr/lib/python2.7/site-packages/gnocchi/storage/_carbonara.py", line 538, in _compute_and_store_timeseries
2017-01-26 12:48:26.436 545651 ERROR gnocchi.storage._carbonara     ignore_too_old_timestamps=True)
2017-01-26 12:48:26.436 545651 ERROR gnocchi.storage._carbonara   File "/usr/lib/python2.7/site-packages/gnocchi/carbonara.py", line 229, in set_values
2017-01-26 12:48:26.436 545651 ERROR gnocchi.storage._carbonara     before_truncate_callback(self)
2017-01-26 12:48:26.436 545651 ERROR gnocchi.storage._carbonara   File "/usr/lib/python2.7/site-packages/gnocchi/storage/_carbonara.py", line 533, in _map_add_measures
2017-01-26 12:48:26.436 545651 ERROR gnocchi.storage._carbonara     for aggregation in agg_methods))
2017-01-26 12:48:26.436 545651 ERROR gnocchi.storage._carbonara   File "/usr/lib/python2.7/site-packages/gnocchi/storage/_carbonara.py", line 650, in _map_no_thread
2017-01-26 12:48:26.436 545651 ERROR gnocchi.storage._carbonara     return list(itertools.starmap(method, list_of_args))
2017-01-26 12:48:26.436 545651 ERROR gnocchi.storage._carbonara   File "/usr/lib/python2.7/site-packages/gnocchi/storage/_carbonara.py", line 332, in _add_measures
2017-01-26 12:48:26.436 545651 ERROR gnocchi.storage._carbonara     for key, split in ts.split():
2017-01-26 12:48:26.436 545651 ERROR gnocchi.storage._carbonara   File "/usr/lib/python2.7/site-packages/gnocchi/carbonara.py", line 470, in split
2017-01-26 12:48:26.436 545651 ERROR gnocchi.storage._carbonara     keys, counts = numpy.unique((ix // freq) * freq, return_counts=True)
2017-01-26 12:48:26.436 545651 ERROR gnocchi.storage._carbonara TypeError: unique() got an unexpected keyword argument 'return_counts'



Expected results:


Additional info:

One thing to note here is numpy 1.9 has a slight incompatibility with Gnocchi metricd, there is an outstanding patch to address for that version (https://review.openstack.org/#/c/425695/) so possibly the version with the numpy fix or if gnocchi metricd is patched earlier we will have working telemetry services then.


Lastly, I am not sure if this is the correct component but this should be a bug against the overcloud images.

Comment 1 Franck Baudin 2017-02-02 15:10:40 UTC

*** This bug has been marked as a duplicate of bug 1417881 ***


Note You need to log in before you can comment on or make changes to this bug.