Bug 1416845 - Can not add power management to the host, when the host has state 'UP'
Summary: Can not add power management to the host, when the host has state 'UP'
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Infra
Version: 4.1.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ovirt-4.1.1
: 4.1.1
Assignee: Ravi Nori
QA Contact: Petr Matyáš
URL:
Whiteboard:
: 1435742 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-26 15:14 UTC by Artyom
Modified: 2017-04-21 09:38 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-21 09:38:00 UTC
oVirt Team: Infra
rule-engine: ovirt-4.1+
rule-engine: blocker+
lsvaty: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 71546 0 master MERGED engine: Can not add power management to the host, when the host has state 'UP' 2017-02-02 10:48:13 UTC
oVirt gerrit 71818 0 ovirt-engine-4.1 MERGED engine: Can not add power management to the host, when the host has state 'UP' 2017-02-08 08:26:06 UTC

Description Artyom 2017-01-26 15:14:58 UTC
Description of problem:
Can not add power management to the host, when the host has state 'UP'

Version-Release number of selected component (if applicable):
rhevm-4.1.0.2-0.2.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Add host to the engine
2. Try to add power management to the host without putting the host to the maintenance
3.

Actual results:
Operation Canceled


Error while executing action: 

host_mixed_1:
Cannot edit Host. Host parameters cannot be modified while Host is operational.
Please switch Host to Maintenance mode first.

Expected results:
Adding power management succeeds

Additional info:
Update of the host name fails with the same error
In 4.0 I had the possibility to update the host name and add power management to the host, without putting it to the maintenance.

Comment 2 Red Hat Bugzilla Rules Engine 2017-02-01 13:11:41 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 3 Petr Matyáš 2017-02-15 08:55:57 UTC
Verified on 4.1.1-1

Comment 4 Alex Kaouris 2017-03-01 09:55:41 UTC
Encountered also on my setup with oVirt Engine Version: 4.1.0.4-1.el7.centos. 
and hosts running on top CentOS Linux release 7.3.1611 with below packages: 

ovirt-imageio-proxy-setup-1.0.0-0.201701151456.git89ae3b4.el7.centos.noarch
ovirt-engine-hosts-ansible-inventory-4.1.0.4-1.el7.centos.noarch
ovirt-engine-backend-4.1.0.4-1.el7.centos.noarch
ovirt-setup-lib-1.1.0-1.el7.centos.noarch
ovirt-engine-wildfly-10.1.0-1.el7.x86_64
ovirt-engine-setup-plugin-websocket-proxy-4.1.0.4-1.el7.centos.noarch
ovirt-engine-restapi-4.1.0.4-1.el7.centos.noarch
ovirt-release41-4.1.0-1.el7.centos.noarch
ovirt-engine-extension-aaa-jdbc-1.1.2-1.el7.noarch
python-ovirt-engine-sdk4-4.1.0-1.el7.centos.x86_64
ovirt-vmconsole-host-1.0.4-1.el7.centos.noarch
ovirt-engine-dwh-4.1.0-1.el7.centos.noarch
ovirt-engine-websocket-proxy-4.1.0.4-1.el7.centos.noarch
ovirt-engine-tools-4.1.0.4-1.el7.centos.noarch
ovirt-engine-dashboard-1.1.0-1.el7.centos.noarch
ovirt-engine-vmconsole-proxy-helper-4.1.0.4-1.el7.centos.noarch
ovirt-engine-sdk-python-3.6.9.1-1.el7.centos.noarch
ovirt-engine-extensions-api-impl-4.1.0.4-1.el7.centos.noarch
ovirt-imageio-common-1.0.0-1.el7.noarch
ovirt-engine-wildfly-overlay-10.0.0-1.el7.noarch
ovirt-engine-setup-base-4.1.0.4-1.el7.centos.noarch
ovirt-web-ui-0.1.1-2.el7.centos.x86_64
ovirt-vmconsole-1.0.4-1.el7.centos.noarch
ovirt-engine-setup-plugin-ovirt-engine-common-4.1.0.4-1.el7.centos.noarch
ovirt-imageio-proxy-1.0.0-0.201701151456.git89ae3b4.el7.centos.noarch
ovirt-iso-uploader-4.0.2-1.el7.centos.noarch
ovirt-engine-userportal-4.1.0.4-1.el7.centos.noarch
ovirt-engine-webadmin-portal-4.1.0.4-1.el7.centos.noarch
ovirt-engine-setup-plugin-vmconsole-proxy-helper-4.1.0.4-1.el7.centos.noarch
ovirt-host-deploy-1.6.0-1.el7.centos.noarch
ovirt-engine-lib-4.1.0.4-1.el7.centos.noarch
ovirt-hosted-engine-ha-2.1.0.1-1.el7.centos.noarch
ovirt-engine-appliance-4.1-20170201.1.el7.centos.noarch
ovirt-imageio-daemon-1.0.0-1.el7.noarch
ovirt-vmconsole-proxy-1.0.4-1.el7.centos.noarch
ovirt-hosted-engine-setup-2.1.0.1-1.el7.centos.noarch
ovirt-engine-tools-backup-4.1.0.4-1.el7.centos.noarch
ovirt-engine-dbscripts-4.1.0.4-1.el7.centos.noarch
ovirt-engine-setup-plugin-ovirt-engine-4.1.0.4-1.el7.centos.noarch
ovirt-engine-cli-3.6.9.2-1.el7.centos.noarch
ovirt-engine-dwh-setup-4.1.0-1.el7.centos.noarch
ovirt-engine-setup-4.1.0.4-1.el7.centos.noarch
ovirt-engine-4.1.0.4-1.el7.centos.noarch
ovirt-host-deploy-java-1.6.0-1.el7.centos.noarch

Comment 5 Martin Perina 2017-03-01 15:20:51 UTC
(In reply to Alex Kaouris from comment #4)
> Encountered also on my setup with oVirt Engine Version:
> 4.1.0.4-1.el7.centos. 
> and hosts running on top CentOS Linux release 7.3.1611 with below packages: 
> 

Yes, this will be delivered within oVirt 4.1.1

Comment 6 Martin Perina 2017-04-03 12:27:40 UTC
*** Bug 1435742 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.