Bug 1416860 - httpd logs 'bogus version' followed by 'error dispatching request'
Summary: httpd logs 'bogus version' followed by 'error dispatching request'
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: httpd
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Luboš Uhliarik
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks: 1724990
TreeView+ depends on / blocked
 
Reported: 2017-01-26 15:57 UTC by BasG
Modified: 2020-11-11 21:46 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-11 21:46:25 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description BasG 2017-01-26 15:57:36 UTC
Description of problem:

In the apache error logs we find: 

`AH01068: Got bogus version [xxx], referer: [url]`

Whereby version number [xxx] seems to vary per log-entry.

These entries are usually followed by one or more of these entries: 

`Invalid argument: [client IP-address] AH01075: Error dispatching request to :, referer: [url]`


Fixes for this problem have been released by the Apache developers, please see Apache bugreports 57398 and 49671 in the following links for more information:

https://bz.apache.org/bugzilla/show_bug.cgi?id=57398
https://bz.apache.org/bugzilla/show_bug.cgi?id=49671

Please include these fixes in the Enterprise Linux packages. 



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Joe Orton 2017-02-07 08:16:24 UTC
Thank you for taking the time to report this issue to us. We appreciate the feedback and use reports such as this one to guide our efforts at improving our products. That being said, this bug tracking system is not a mechanism for requesting support, and we are not able to guarantee the timeliness or suitability of a resolution.

If this issue is critical or in any way time sensitive, please raise a ticket through the regular Red Hat support channels to ensure it receives the proper attention and prioritization to assure a timely resolution. 

For information on how to contact the Red Hat production support team, please visit: https://www.redhat.com/en/services/support

Comment 5 Dominik Piekarski 2018-09-13 07:38:07 UTC
Any progress on this? It seems to be an Apache2 mod_proxy_fcgi bug that has been fixed a long time ago:

https://bz.apache.org/bugzilla/show_bug.cgi?id=56110
https://bz.apache.org/bugzilla/show_bug.cgi?id=49671

Just upgrade Apache2 to a newer version.

Comment 7 Atul Singh 2019-05-24 14:13:33 UTC
Do we have any further update on this? I am using RHEL 7.6 with httpd version '2.4.6-88'. 

Should I need to update httpd to solve this bug? Let us know so that We could solve this issue.

Thanks

Comment 12 Chris Williams 2020-11-11 21:46:25 UTC
Red Hat Enterprise Linux 7 shipped it's final minor release on September 29th, 2020. 7.9 was the last minor releases scheduled for RHEL 7.
From intial triage it does not appear the remaining Bugzillas meet the inclusion criteria for Maintenance Phase 2 and will now be closed. 

From the RHEL life cycle page:
https://access.redhat.com/support/policy/updates/errata#Maintenance_Support_2_Phase
"During Maintenance Support 2 Phase for Red Hat Enterprise Linux version 7,Red Hat defined Critical and Important impact Security Advisories (RHSAs) and selected (at Red Hat discretion) Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available."

If this BZ was closed in error and meets the above criteria please re-open it flag for 7.9.z, provide suitable business and technical justifications, and follow the process for Accelerated Fixes:
https://source.redhat.com/groups/public/pnt-cxno/pnt_customer_experience_and_operations_wiki/support_delivery_accelerated_fix_release_handbook  

Feature Requests can re-opened and moved to RHEL 8 if the desired functionality is not already present in the product. 

Please reach out to the applicable Product Experience Engineer[0] if you have any questions or concerns.  

[0] https://bugzilla.redhat.com/page.cgi?id=agile_component_mapping.html&product=Red+Hat+Enterprise+Linux+7


Note You need to log in before you can comment on or make changes to this bug.