Bug 1416874 - Unable to resize evince windows in MWM
Summary: Unable to resize evince windows in MWM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gtk3
Version: 7.3
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 7.3
Assignee: Benjamin Otte
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1420851 1444345
TreeView+ depends on / blocked
 
Reported: 2017-01-26 16:52 UTC by Joe Wright
Modified: 2020-06-11 13:14 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1444345 (view as bug list)
Environment:
Last Closed: 2017-08-01 12:28:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2100 normal SHIPPED_LIVE GTK+ bug fix update 2017-08-01 16:06:50 UTC

Description Joe Wright 2017-01-26 16:52:23 UTC
Description of problem:
- Unable to resize evince window in VNC using MWM

Version-Release number of selected component (if applicable):
- current

How reproducible:


Steps to Reproduce:
The issue is successfully reproduced at our end.

Forcefully created mwm :

Put 'PREFERRED=/usr/bin/mwm' in /etc/default/desktop
----------
 yum grouplist
  106  yum groupinstall "Server with GUI"
  107  init 5
  108  xinit -e /usr/bin/mwm 
  109  vi /etc/sysconfig/desktop
  110  yum install motif xterm
  111  startx
  112  evince
  113  yum install tigervnc tigervnc-server
  114  useradd abc
  115  passwd abc
  116  su - abc
  117  cp /lib/systemd/system/vncserver@.service /lib/systemd/system/vncserver@:1.service 
  118  vi /lib/systemd/system/vncserver@:1.service
  119  firewall-cmd  --permanent --zone=public --add-port 5901/tcp
  120  firewall-cmd --reload
  121  systemctl daemon-reload 
  122  systemctl enable vncserver@:1.service
  123  systemctl start vncserver@:1.service
-----------

Steps to reproduce:
1. Login to a RHEL 7.2/RHEL 7.3 machine, physical or virtual
2. Install tigervnc and start a vnc server session with a simple xstartup file, eg. one that executes "exec /etc/X11/xinit/xinitrc"
3. Connect to the VNC session from another machine
4. Start mwm in the VNC session
5. Start evince in the VNC session
6. Try to resize evince by the window border.

Actual results:
- window will not resize

Expected results:
- window size adjustable

Additional info:

Comment 2 Joe Wright 2017-01-26 17:02:56 UTC
installing the latest gtk3-devel and gobject-introspection-devel, and compiling the latest upstream gtk3-nocsd seems to fix this

Comment 4 Thomas Woerner 2017-01-27 13:12:48 UTC
(In reply to Joe Wright from comment #2)
> installing the latest gtk3-devel and gobject-introspection-devel, and
> compiling the latest upstream gtk3-nocsd seems to fix this

This seems to be a gtk3 issue then, right?

Comment 6 Thomas Woerner 2017-01-30 16:02:36 UTC
Reassigning to gtk3.

Comment 14 errata-xmlrpc 2017-08-01 12:28:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2100


Note You need to log in before you can comment on or make changes to this bug.