Bug 1416876 - Request to offer rrdtool-perl in supported base RHEL repo
Summary: Request to offer rrdtool-perl in supported base RHEL repo
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: releng
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 7.4
Assignee: Lubos Kocman
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-26 16:57 UTC by Shruti Sampat
Modified: 2017-08-01 17:32 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 17:32:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1850 normal SHIPPED_LIVE redhat-release update 2017-08-01 18:03:01 UTC

Description Shruti Sampat 2017-01-26 16:57:11 UTC
Description of problem:
-----------------------

RHLog (Red Hat Logging) is a product that is meant to be a place for other products to share common logging packages from. RHLog needs rrdtool-perl, which is currently shipped only to the rhel-7-server-optional-rpms repo. Content shipped to rhel-optional repos is unsupported, as per [1]. Consequently, other products like OpenShift, OpenStack, RHV etc. that consume content from RHLog will need to ship rrdtool-perl into their respective repos. 

Kindly offer the rrdtool-perl package in supported base RHEL repos.

[1] https://access.redhat.com/support/offerings/production/scope_moredetail/

Comment 1 Shruti Sampat 2017-01-26 16:59:48 UTC
Siddharth Nagar, please consider this request to ship rrdtool-perl in supported base RHEL repo.

Comment 2 Lon Hohberger 2017-01-26 18:37:46 UTC
This also affects OpenStack.

RH Logging is used by OpenStack Operational Tools

Comment 4 Lubos Kocman 2017-02-03 12:58:34 UTC

*** This bug has been marked as a duplicate of bug 1354539 ***

Comment 5 Lubos Kocman 2017-02-03 13:00:32 UTC

*** This bug has been marked as a duplicate of bug 1354539 ***

Comment 7 Lubos Kocman 2017-02-03 13:21:48 UTC
Re-considering for explicit addition.

Lubos

Comment 8 Shruti Sampat 2017-02-06 07:54:47 UTC
Thank you, Lubos. Please note that rrdtool-perl in this case is an install dependency, and not a build dependency for rhlog packages.

Comment 9 Jan Stodola 2017-02-21 09:55:02 UTC
Lubos, will rrdtool-perl be added to all archs/variants?

Comment 10 Lubos Kocman 2017-02-21 13:31:47 UTC
Hello Shruti,

which are the variants/arches supported by RHLog? I was trying to search support matrix on product pages but failed.
I'd just meet these requirements and avoid extra inclusion if possible.

Thanks

Lubos

Comment 11 Shruti Sampat 2017-02-22 12:53:22 UTC
Hi Lubos, I have reached out to Richard Megginson for this information and will update this BZ once I have it. Thanks!

Comment 12 Shruti Sampat 2017-02-24 12:07:53 UTC
Hi Lubos, this needs to be added to Server variant and x86_64 and ppc64le arches. Thanks!

Comment 13 Lubos Kocman 2017-03-06 12:51:21 UTC
commit d5c632deaee2976d45a97f0ce6b425b458c3bcab
Author: Lubos Kocman <lkocman@redhat.com>
Date:   Mon Mar 6 07:51:02 2017 -0500

    rhel-7.4/pegas: add rrdtool-perl to Server ppc64le/x86_64. Resolves rhbz#1416876
    
    Change-Id: I395592f18f5eab383e77850678685c3e852410eb

diff --git a/pungi/rhel-7/rhel-7.4/rhel-7.4-pegas.conf b/pungi/rhel-7/rhel-7.4/rhel-7.4-pegas.conf
index 6bce8b8..f71a1b1 100644
--- a/pungi/rhel-7/rhel-7.4/rhel-7.4-pegas.conf
+++ b/pungi/rhel-7/rhel-7.4/rhel-7.4-pegas.conf
@@ -17,6 +17,15 @@ variants_file = {
 
 # fomat: [(variant_uid_regex, {arch|*: [packages]})]
 additional_packages = [
+    # external dependency (layered product)  rhbz#1416876
+    ('^Server$', {
+        'x86_64': [
+            'rrdtool-perl' 
+        ],
+        'ppc64le': [
+            'rrdtool-perl'
+        ],
+    }),
 
     #libunwind on aarch64/ppc64le rhbz#1426713
     ('^Server$', {
diff --git a/pungi/rhel-7/rhel-7.4/rhel-7.4.conf b/pungi/rhel-7/rhel-7.4/rhel-7.4.conf
index ce44e95..9adca38 100644
--- a/pungi/rhel-7/rhel-7.4/rhel-7.4.conf
+++ b/pungi/rhel-7/rhel-7.4/rhel-7.4.conf
@@ -87,6 +87,15 @@ create_optional_isos = False
 
 # fomat: [(variant_uid_regex, {arch|*: [packages]})]
 additional_packages = [
+    # external dependency (layered product)  rhbz#1416876
+    ('^Server$', {
+        'x86_64': [
+            'rrdtool-perl' 
+        ],
+        'ppc64le': [
+            'rrdtool-perl'
+        ],
+    }),
 
     #libunwind on aarch64/ppc64le rhbz#1426713
     ('^Server$', {

Comment 16 errata-xmlrpc 2017-08-01 17:32:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1850


Note You need to log in before you can comment on or make changes to this bug.