Bug 1416882 - Allow Users to Specify Percentages Instead of Weight when Setting up Split Traffic Routes
Summary: Allow Users to Specify Percentages Instead of Weight when Setting up Split Tr...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-26 17:05 UTC by Nick Schuetz
Modified: 2017-07-24 14:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
When creating or editing routes that send traffic to 2 services in the web console, you can now specify the service weights as percentages using a slider control. Previously you had to enter weights between 0-256 as integer values. You still have the option to enter integer weights if desired.
Clone Of:
Environment:
Last Closed: 2017-04-12 19:10:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0884 0 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.5 RPM Release Advisory 2017-04-12 22:50:07 UTC

Description Nick Schuetz 2017-01-26 17:05:57 UTC
Description of problem:

When setting up a split route in the UI, the user is only able to specify weight 0-256. I suggest we give them the ability to use percentages because it is more intuitive. This I believe would make for a better user experience.

Version-Release number of selected component (if applicable):

3.4.0.40

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Samuel Padgett 2017-01-26 19:26:02 UTC
We've added a slider to set weights as a percentage if there are two services.

https://github.com/openshift/origin-web-console/pull/1053

Comment 2 Troy Dawson 2017-01-27 17:26:29 UTC
This has been merged into ocp and is in OCP v3.5.0.10 or newer.

Comment 4 Yanping Zhang 2017-02-03 02:05:53 UTC
Checked on OCP v3.5.0.14, When create or edit route and split traffic across two services, there is a slider for user to set percentage directly. And if split traffic across more than 2 services, user still needs set weight for services.

Comment 7 errata-xmlrpc 2017-04-12 19:10:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0884


Note You need to log in before you can comment on or make changes to this bug.