Bug 1416928 - docker: Pull in package parted during install
Summary: docker: Pull in package parted during install
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: container-storage-setup
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Frantisek Kluknavsky
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1215146
TreeView+ depends on / blocked
 
Reported: 2017-01-26 19:46 UTC by Vivek Goyal
Modified: 2017-12-01 14:46 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1416929 (view as bug list)
Environment:
Last Closed: 2017-12-01 14:46:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3371 0 normal SHIPPED_LIVE container-storage-setup enhancement update 2017-12-01 19:46:25 UTC

Description Vivek Goyal 2017-01-26 19:46:46 UTC
Description of problem:

docker-storage-setup will rely on parted to do partition management. sfdisk does not work on certain disks and on rhel/centos we have old sfdisk (util-linux) and it is considered risky to upgrade to newer util-linux.k

Given we can't get newer util-linux, lets pull in parted which does not
have issues sfdisk has. That should allow docker-storage-setup to work well
on rhel/centos.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Daniel Walsh 2017-01-26 20:56:11 UTC
So we should add 
Requires: parted to docker-storage-setup.

Comment 3 Lokesh Mandvekar 2017-01-26 21:03:39 UTC
(In reply to Daniel Walsh from comment #2)
> So we should add 
> Requires: parted to docker-storage-setup.

Well this will be to the 'docker' package itself, since there's no docker-storage-setup subpackage atm.

Comment 4 Vivek Goyal 2017-01-26 21:15:41 UTC
Right. Once we have a separate package for docker-storage-setup, this Requires
dependency can move there.

Comment 6 Daniel Walsh 2017-06-30 15:27:44 UTC
Is this fixed now that we have container-storage-setup?

Comment 9 Fedora Update System 2017-10-26 12:10:19 UTC
container-storage-setup-0.8.0-2.git1d27ecf.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-04c837a3df

Comment 10 Fedora Update System 2017-10-26 13:30:29 UTC
container-storage-setup-0.8.0-2.git1d27ecf.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-210d19bdd9

Comment 12 Fedora Update System 2017-10-27 15:38:56 UTC
container-storage-setup-0.8.0-2.git1d27ecf.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-210d19bdd9

Comment 13 Fedora Update System 2017-10-27 18:48:59 UTC
container-storage-setup-0.8.0-2.git1d27ecf.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-04c837a3df

Comment 14 Fedora Update System 2017-11-11 03:06:22 UTC
container-storage-setup-0.8.0-2.git1d27ecf.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2017-11-15 20:12:53 UTC
container-storage-setup-0.8.0-2.git1d27ecf.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 errata-xmlrpc 2017-12-01 14:46:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3371


Note You need to log in before you can comment on or make changes to this bug.