Bug 1417 - free list corrupt error with rpm -Uvh
free list corrupt error with rpm -Uvh
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
5.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeff Johnson
:
: 1425 1433 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-03-04 01:27 EST by Raul Acevedo
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-14 14:11:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raul Acevedo 1999-03-04 01:27:16 EST
I downloaded all the latest RPMs for GNOME 1.0, and did an
rpm -Uvh on the whole thing at once.  After gnumeric, I got
the following:

free list corrupt (14736712)- contact support@redhat.com

I tried upgrading the other packages, but then I got the
exact same message on gtk+-devel.  I tried removing all the
GNOME-related RPMs, then installing them again, but now I
get the error on enlightenment (which hadn't given the error
before).

So, at this point, I think I'm pretty screwed, because my
feeling is that one or more of the RPM files in /var/lib
have somehow gotten corrupted.  This means that I have to
reinstall my whole system, if I ever want to use RPM
again... I'm pretty sure I have a backup of /var/lib/rpm
that I can try working from, which might save me that, but
it might not work, especially if the corruption happened
before I tried to do the GNOME thing (or if the corruption
is going to be triggered by the GNOME packages).
Comment 1 cjwoods 1999-03-05 12:37:59 EST
I get this too, RH5.2, rpm -Uvh kills me. Trying to install Gnome-1.0.
I have successfully installed it at home, and have been able to
successfully install other packages previously.
Comment 2 tunacat 1999-03-08 01:44:59 EST
Glad to see other people are having the problem too.  Same thing
happens for me trying to install Gnome 1.0: rpm -Uvh *.rpm
generates: free list corrupt (3746440)- contact support@redhat.com.
Previous versions of Gnome gave me no problems.
Comment 3 Jeff Johnson 1999-03-08 23:14:59 EST
*** Bug 1425 has been marked as a duplicate of this bug. ***

I was installing the new GNOME 1.0.1 using the command

RPM -Uvh *

when the entire process hung on me.  I used the command
'kill -9 pid' to kill the process.

Now when I try to pick up from where i left off it gives me
the error message

free list corrupt (6964424)- contact support@redhat.com

so I did, but the mailer sent it back to me.

Patrick Stockton
Comment 4 Jeff Johnson 1999-03-08 23:15:59 EST
*** Bug 1433 has been marked as a duplicate of this bug. ***

While installing GNOME 1.0 from RPMs I got this error.

free list corrupt (4044808)- contact support@redhat.com

I can add some RPMs, but others return the same error.
Unfortunately now I have a half-installation between .99.2
and 1.0 and my panel won't work anymore.

Thanks,
Matt Ray
Comment 5 tunacat 1999-03-21 17:30:59 EST
Okay, I got tired of waiting for the "solution", so I poked around the
rpm code.  Then I noticed a "rebuilddb" option.  Hmmm.. why did I
never see that when I looked in the man page?  Oh, there it is, with a
one line description.  So I tried it out and it worked for me.
rpm --rebuilddb
got rid of the "corruption".  One of the db blocks was listed in the
free list but wasn't free or something.  This doesn't explain why it
got corrupted in the first place, but at least I'm running again.
Maybe this will help someone else who, like me, doesn't know very much
about rpm.
Comment 6 Jeff Johnson 1999-03-21 17:40:59 EST
Sorry, I dunno what the original problem is/was so there is
no solution yet because we can't reproduce the problem here.

But the work around is indeed

	rpm --rebuilddb
Comment 7 roystgnr 1999-03-22 02:08:59 EST
In short, "me too".

I got the same error, got it installing the GNOME 1.01 RPMs, and fixed
it (apparantly) with "rpm --rebuilddb".
Comment 8 Jeff Johnson 1999-05-04 12:48:59 EDT
I believe this problem is caused by attempting to install two versions
of the same package simultaneously, as in
	rpm -U foo*.i386.rpm foo*.i386.rpm
For now (and probably the near future): Don't do that!
And if you do happen to install 2 versions of the same package
simultaneously, you will need to do "rpm --rebuilddb"
Comment 9 Jeff Johnson 1999-05-24 16:11:59 EDT
The usual trigger for this problem is when two nearly identical
copies of an rpm are being installed on the same command line.
For now, the work around is "Don't do that." And if you did do
that, remember to do
	rpm --rebuilddb
Comment 10 Jeff Johnson 2000-10-22 15:15:52 EDT
rpm-4.0 uses Berkeley db-3.1.14 to avoid "free list corrupt' problems with the
rpm-3.0.x  (and
earlier) implementation.

Note You need to log in before you can comment on or make changes to this bug.