Bug 1417012 - Only root can run the Xorg server (multi-user mode)/Only root can log in (graphics mode)
Summary: Only root can run the Xorg server (multi-user mode)/Only root can log in (gra...
Keywords:
Status: CLOSED DUPLICATE of bug 1417011
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 25
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-27 00:35 UTC by wwaustin
Modified: 2017-01-27 16:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-27 16:09:02 UTC
Type: Bug


Attachments (Terms of Use)

Description wwaustin 2017-01-27 00:35:29 UTC
Description of problem:
After doing a clean install (Fedora FC25) of the workstation O/S, if the computer is in graphics only mode, no user except root can log in to the GUI.
(This was only a test- the machine runs normally in multi-user mode).
Users can log in; however, only root can get an X window session via startx.

I thought it was an install problem, and wiped out and redid the installation.
The results were unchanged.  Only root can run X windows.


Version-Release number of selected component (if applicable): (occurs with all kernels, and all xorg packages used so far, and is unchanged if I install the proprietary NVIDIA driver instead of using the nouveau driver.)

kernel-4.1.13-100.fc21.x86_64
xorg-x11-drv-nvidia-340xx-340.96-1.fc21.x86_64

How reproducible:

100%

Steps to Reproduce:
1.Boot machine in multiuser mode
2.log in as anybody but root
3.run startx

Actual results:
Server tries to load (screen blanks briefly) then fails.  No useful info in /var/log/Xorg.0.log
Error message resembles fragment of a shell script repeated 3-6 times.
(The fragment
        ?? is not a valid number"; # wait until
is repeated multiple times. Presumably the first part ending in the ";" is part of an error message, and the part following the pound sign begins a comment.  But that's just an educated guess... sorry)

Occasionally (see below under Additional...) the message is preceded by the message:
        Only console users are permitted to run the X server
(this is from memory - may be slightly "off").

Expected results:
X session should begin normally

Additional info:

Similar results for a non-privileged user in graphics-only mode.  Try to log in, screen goes black, eventually you're back at the login prompt.

I have verified the checksum on both copies of the DVD (identical) against the one in the file.  It is correct.

The problem clearly acts like a permissions problem, but I can't find it.

If I put the previous root HD back in and start up (no changes to the hardware) with FC23, everything works correctly and the x sessions start properly.

One possible "irritating" issue connected to this is that there appears to be NO way (short of removing the gnome desktop altogether) to run any desktop except gnome from the multi-user system.  As we have apps which are kde specific, 
gnome is not useful here.

I will send full machine particulars, logs, etc. if you will let me know what you need.  (sorry but I'm not sure which ones you'll need).

A situation exists which may have an impact here.  My ISP has been having service problems for 2 weeks (replacing cables), and as a result my internet connection drops 3-5 times a day.  When it has dropped, the error message "Only Console Users are allowed .." shows up but is absent when there is a connection.  This one makes no sense to me, but I'm including it just in case.

Comment 1 wwaustin 2017-01-27 16:09:02 UTC
Please kill this bug report.  My internet connection went down while I was creating this report, and I must have submitted it a second time without realizing it when my connection came bck up.

*** This bug has been marked as a duplicate of bug 1417011 ***


Note You need to log in before you can comment on or make changes to this bug.