Bug 1417053 - hammer host create returns "ip can't be blank" with interface attached to subnet with IPAM set to internal DB
Summary: hammer host create returns "ip can't be blank" with interface attached to sub...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hosts
Version: 6.2.6
Hardware: All
OS: All
high
high vote
Target Milestone: Unspecified
Assignee: Tomas Strachota
QA Contact: Sanket Jagtap
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-27 06:32 UTC by Anand Agrawal
Modified: 2020-05-14 15:34 UTC (History)
12 users (show)

Fixed In Version: foreman-1.11.0.89-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-21 20:16:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1672 None None None 2018-05-21 20:17:45 UTC

Comment 3 Marek Hulan 2017-01-30 11:38:24 UTC
Looking at the subnet setting it's likely caused by the fact the interface is attached to a subnet which IPAM is set to Internal DB. We need few tests but IIRC the UI does the autosuggestion so it works there. A temporary workaround is to set the IP manually as another argument for that NIC.

Comment 5 Tomas Strachota 2017-03-07 08:27:20 UTC
Created redmine issue http://projects.theforeman.org/issues/18817 from this bug

Comment 20 Sanket Jagtap 2018-04-25 08:41:33 UTC
Build : Satellite 6.2.15 snap1

hammer -d host create --hostgroup-id 2 --location "Default Location" --organization "Default Organization" --name robtest-sjagtap --compute-resource libvirt --compute-profile 2-Medium --lifecycle-environment DEV --content-view "RHEL 7 CV" --interface identifier=eth0,primary=false,provision=true,managed=true,subnet_id=2,compute_type=bridge,compute_network="testingsat6_el7",compute_model=virtio --interface identifier=eth1,primary=true,provision=false,managed=true,subnet_id=3,compute_type=bridge,compute_network="testingsat6_el7",compute_model=virtio

I was able to create a host and IP address was assigned to both the interfaces

Comment 24 errata-xmlrpc 2018-05-21 20:16:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1672


Note You need to log in before you can comment on or make changes to this bug.