Bug 1417100 - imgbased make distcheck fails
Summary: imgbased make distcheck fails
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-node
Classification: oVirt
Component: Build
Version: 4.1
Hardware: Unspecified
OS: Unspecified
low
low vote
Target Milestone: ovirt-4.1.1
: 4.1
Assignee: Ryan Barry
QA Contact: Ryan Barry
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-27 08:53 UTC by Sandro Bonazzola
Modified: 2017-04-21 09:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-21 09:31:03 UTC
oVirt Team: Node
rule-engine: ovirt-4.1+
ycui: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 71301 master MERGED fix 'make distcheck' 2017-02-15 13:34:41 UTC
oVirt gerrit 72363 ovirt-4.1 MERGED fix 'make distcheck' 2017-02-15 13:35:38 UTC

Description Sandro Bonazzola 2017-01-27 08:53:30 UTC
Description of problem:
imgbased make distcheck fails with:
make[1]: Entering directory '/NotBackedUp/sbonazzo/upstream/imgbased/imgbased-0.9.6/_build/sub'
[CHECK] pyflakes
[CHECK] pep8
[CHECK] nosetests

Coverage.py warning: Module imgbased was never imported.
Name    Stmts   Miss Branch BrPart  Cover   Missing
---------------------------------------------------
Traceback (most recent call last):
  File "/usr/bin/nosetests", line 9, in <module>
    load_entry_point('nose==1.3.7', 'console_scripts', 'nosetests-2.7')()
  File "/usr/lib/python2.7/site-packages/nose/core.py", line 121, in __init__
    **extra_args)
  File "/usr/lib64/python2.7/unittest/main.py", line 95, in __init__
    self.runTests()
  File "/usr/lib/python2.7/site-packages/nose/core.py", line 207, in runTests
    result = self.testRunner.run(self.test)
  File "/usr/lib/python2.7/site-packages/nose/core.py", line 66, in run
    result.printErrors()
  File "/usr/lib/python2.7/site-packages/nose/result.py", line 110, in printErrors
    self.config.plugins.report(self.stream)
  File "/usr/lib/python2.7/site-packages/nose/plugins/manager.py", line 99, in __call__
    return self.call(*arg, **kw)
  File "/usr/lib/python2.7/site-packages/nose/plugins/manager.py", line 167, in simple
    result = meth(*arg, **kw)
  File "/usr/lib/python2.7/site-packages/nose/plugins/cover.py", line 190, in report
    self.coverInstance.report(modules, file=stream, show_missing=True)
  File "/usr/lib64/python2.7/site-packages/coverage/control.py", line 985, in report
    return reporter.report(morfs, outfile=file)
  File "/usr/lib64/python2.7/site-packages/coverage/summary.py", line 140, in report
    raise CoverageException("No data to report.")
coverage.misc.CoverageException: No data to report.
Makefile:939: recipe for target 'check-nosetests' failed
make[1]: *** [check-nosetests] Error 1
make[1]: Leaving directory '/NotBackedUp/sbonazzo/upstream/imgbased/imgbased-0.9.6/_build/sub'
Makefile:675: recipe for target 'distcheck' failed
make: *** [distcheck] Error 1


Version-Release number of selected component (if applicable):
0.9.6

How reproducible:
100% on FC25

Comment 1 Sandro Bonazzola 2017-02-15 14:38:28 UTC
Moving to modified since both referenced patches are merged.

Comment 2 cshao 2017-02-20 09:52:06 UTC
Ryan, 

We QE currently might not familiar how to test imgbased make distcheck, so could you please help to verify this bug after it is fixed?

If yes, I will change the QA contact to you.

Thanks.

Comment 3 Ryan Barry 2017-02-20 13:06:45 UTC
Sure, I'll verify.

Comment 4 Ying Cui 2017-03-15 01:34:50 UTC
Ryan, could you change the bug status to VERIFIED once it is fixed.


Note You need to log in before you can comment on or make changes to this bug.