Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1417166 - [enhancement] rxvt-unicode compiled with unicode3 flag
Summary: [enhancement] rxvt-unicode compiled with unicode3 flag
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: rxvt-unicode
Version: 25
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-27 12:01 UTC by Davide Maglio
Modified: 2018-11-15 19:05 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Unicode3 flag Reason: Incompatible with powerline symbol Result:
Clone Of:
Environment:
Last Closed: 2017-12-12 10:39:36 UTC
Type: Bug


Attachments (Terms of Use)
actual situation (8.99 KB, image/png)
2017-01-27 12:01 UTC, Davide Maglio
no flags Details

Description Davide Maglio 2017-01-27 12:01:14 UTC
Created attachment 1245104 [details]
actual situation

Description of problem:
When i try to use Powerline into urxvt256 i don't see powerline symbol. i have installed powerline fonts but still not working. it's only an enhancement 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:



Expected results:


Additional info:

Comment 1 Luke Hinds 2017-02-25 10:26:03 UTC
I have this issue too, and looking into this (unless I have misunderstood something), rxvt-unicode is compiled without any unicode support at all

urxvt --help 2>&1 | grep options
options: perl,xft,styles,combining,blink,encodings=eu+vn+jp+jp-ext+kr+zh+zh-ext,fade,transparent,tint,pixbuf,XIM,frills,selectionscrolling,wheel,slipwheel,smart-resize,cursorBlink,pointerBlank,scrollbars=plain+rxvt+NeXT+xterm

This is quite a key feature as a lot of users often run powerline and need unicode support.

Comment 2 Benjamin N 2017-06-03 11:33:37 UTC
Hi guys,

As we can see in the specs (https://apps.fedoraproject.org/packages/rxvt-unicode-256color/sources/spec/), the package rxvt-unicode-256color is not compile with unicode3, but the multilingual version is (rxvt-unicode-ml). I don't know if it is on purpose, anyway a simple workaround is to install and use rxvt-unicode-ml.

Regards,

Comment 3 Fedora End Of Life 2017-11-16 19:46:10 UTC
This message is a reminder that Fedora 25 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 25. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '25'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 25 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 4 Fedora End Of Life 2017-12-12 10:39:36 UTC
Fedora 25 changed to end-of-life (EOL) status on 2017-12-12. Fedora 25 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Comment 5 Michal Halenka 2018-07-16 15:06:12 UTC
This is still valid on Fedora 28

rxvt-unicode3 is still not not compiled with unicode3 option, which causes powerline symbols and other unicode characters display uncorrectly. 

# urxvt --help                                    
rxvt-unicode (urxvt) v9.22 - released: 2016-01-23
options: perl,xft,styles,combining,blink,encodings=eu+vn+jp+jp-ext+kr+zh+zh-ext,fade,transparent,tint,pixbuf,XIM,frills,selectionscrolling,wheel,slipwheel,smart-resize,cursorBlink,pointerBlank,scrollbars=plain+rxvt+NeXT+xterm
Usage: urxvt [options] [-e command args]
...

Comment 6 Jan Pokorný [poki] 2018-11-15 19:05:24 UTC
I believe two things are being, regrettably, conflated here:

1. some compiled variants of urxvt are not compiled with "unicode3"
   option

2. Powerline doesn't work out of the box, even when powerline-fonts
   package installed and urxvt properly configured to use it
   (e.g. via "-fn xft:...,xft:powerline") and that's because
   powerline-fonts carries rather a fouled font in a way it doesn't
   contain any "standard" character urxvt could use to get the font
   metrics (width) right:

   https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/CDBIOLOE6W7W7RHVBWFXZ5DJ3AOOZT7G/


Solutions:

re 1.: use the variants that are "unicode3" per [comment 2], end of story

re 2., diehard variant:
       work with powerline-fonts upstream and persuade them to make the
       font sane so that the width can be detected correctly in urxvt
       (or converesely, with urxvt upstream that it needs more
        sophisticated way to detect such width if at all possible)

re 2., easy variant (this is what I am sticking with for the time being):
       install and use the explicitly patched variant of your favourite
       (monospace) font: https://github.com/powerline/fonts

All in all, please stop conflating two separate issues.  Merely based
on the bug summary of this bug, the problem was with 1. which is
a solved problem so that's rightfully closed now.  You can open a new
one regarding point 2., but that could/should as well be targeting
powerline-fonts, i.e. powerline component.


Note You need to log in before you can comment on or make changes to this bug.