Fedora Account System
Red Hat Associate
Red Hat Customer
Description of problem: Upon EVM restart, MiqUiWorker and associated processes (MiqWebServiceWorker, MiqWebsocketWorker) fail to start. No errors reported in the logs and appliance UI no longer accessible. No discernible configuration changes made prior to this behaviour. This has occurred twice, with freshly installed appliances. Version-Release number of selected component (if applicable): VMware appliance version 5.7.0.17. How reproducible: Steps to Reproduce: 1. Import example database (to be provided). 2. 3. Actual results: Expected results: Additional info: Roles are enabled: [root@localhost ~]# vmdb [root@localhost vmdb]# rails c irb(main):001:0> MiqServer.my_server.assigned_role_names PostgreSQLAdapter#log_after_checkout, connection_pool: size: 5, connections: 1, in use: 1, waiting_in_queue: 0 => ["automate", "database_operations", "database_owner", "ems_inventory", "ems_operations", "event", "reporting", "scheduler", "smartstate", "user_interface", "web_services", "websocket"]
This should be fixed by https://github.com/ManageIQ/manageiq/pull/13976 which allows the server to continue on to monitoring other worker classes even if one raises an error. The underlying issue is described here https://github.com/ManageIQ/manageiq/issues/13958
Verified in 5.8.0.13