Bug 1417181 - Users are not removed from database when they are removed in UI
Summary: Users are not removed from database when they are removed in UI
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.0.5
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
: ---
Assignee: Nobody
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-27 12:34 UTC by Marian Jankular
Modified: 2020-06-11 13:15 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-28 11:58:49 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)

Description Marian Jankular 2017-01-27 12:34:08 UTC
Description of problem:
Users are not removed from database when they are removed in UI

Version-Release number of selected component (if applicable):
Users are not removed from database when they are removed in UI

How reproducible:


Steps to Reproduce:
1.connect rhv-m 4.0.5 to active directory with startTLS
2.add account with super user role
3.remove account

Actual results:
accounts remain in db

Expected results:
acounts will be removed from db

Additional info:
info from audit log and engfine log

2017-01-25 12:26:52.868+01 |      868 | 1d73e5c9       |             | User/Group user1 Role SuperUser permission was removed from System by adminaccount@example.com@example.com-authz
 2017-01-25 12:27:06.108+01 |      868 | 4f582e80       |             | User/Group user2 Role SuperUser permission was removed from System by adminaccount@example.com@example.com-authz
 2017-01-25 12:27:09.942+01 |      868 | 2066b214       |             | User/Group user3 Role SuperUser permission was removed from System by adminaccount@example.com@example.com-authz
 2017-01-25 12:27:22.776+01 |      868 | 2386122d       |             | User/Group user4 Role SuperUser permission was removed from System by adminaccount@example.com@example.com-authz




2017-01-25 12:26:52,855 INFO  [org.ovirt.engine.core.bll.RemoveSystemPermissionCommand] (org.ovirt.thread.pool-6-thread-12) [1d73e5c9] Running command: RemoveSystemPermissionCommand internal: false. Entities affected :  ID: aaa00000-0000-0000-0000-123456789aaa Type: SystemAction group MANIPULATE_PERMISSIONS with role type USER
2017-01-25 12:26:52,871 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (org.ovirt.thread.pool-6-thread-12) [1d73e5c9] Correlation ID: 1d73e5c9, Call Stack: null, Custom Event ID: -1, Message: User/Group user1 Role SuperUser permission was removed from System by adminaccount@example.com@example.com-authz
2017-01-25 12:27:06,101 INFO  [org.ovirt.engine.core.bll.RemoveSystemPermissionCommand] (org.ovirt.thread.pool-6-thread-9) [4f582e80] Running command: RemoveSystemPermissionCommand internal: false. Entities affected :  ID: aaa00000-0000-0000-0000-123456789aaa Type: SystemAction group MANIPULATE_PERMISSIONS with role type USER
2017-01-25 12:27:06,111 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (org.ovirt.thread.pool-6-thread-9) [4f582e80] Correlation ID: 4f582e80, Call Stack: null, Custom Event ID: -1, Message: User/Group user2 Role SuperUser permission was removed from System by adminaccount@example.com@example.com-authz
2017-01-25 12:27:09,932 INFO  [org.ovirt.engine.core.bll.RemoveSystemPermissionCommand] (org.ovirt.thread.pool-6-thread-16) [2066b214] Running command: RemoveSystemPermissionCommand internal: false. Entities affected :  ID: aaa00000-0000-0000-0000-123456789aaa Type: SystemAction group MANIPULATE_PERMISSIONS with role type USER
2017-01-25 12:27:09,948 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (org.ovirt.thread.pool-6-thread-16) [2066b214] Correlation ID: 2066b214, Call Stack: null, Custom Event ID: -1, Message: User/Group user3 Role SuperUser permission was removed from System by adminaccount@example.com@example.com-authz
2017-01-25 12:27:22,749 INFO  [org.ovirt.engine.core.bll.RemoveSystemPermissionCommand] (org.ovirt.thread.pool-6-thread-19) [2386122d] Running command: RemoveSystemPermissionCommand internal: false. Entities affected :  ID: aaa00000-0000-0000-0000-123456789aaa Type: SystemAction group MANIPULATE_PERMISSIONS with role type USER
2017-01-25 12:27:22,779 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (org.ovirt.thread.pool-6-thread-19) [2386122d] Correlation ID: 2386122d, Call Stack: null, Custom Event ID: -1, Message: User/Group user4 Role SuperUser permission was removed from System by adminaccount@example.com@example.com-authz

Comment 1 Martin Perina 2017-08-01 21:06:58 UTC
I'm not able to reproduce the issue, when you go to Users tab, select the user and invoke Remove then the user along with all assigned permissions is removed from database.

Also in above log snippet I don't see invocation of RemoveUserCommand, there are only RemoveSystemPermissionCommand, so are you sure that you removed a user and not only its system permission?

Comment 2 Martin Perina 2017-08-17 12:20:09 UTC
Marian, any progress getting requested info?

Comment 3 Martin Perina 2017-08-28 11:58:49 UTC
I'm not able to reproduce the issue, details in Comment 1. Feel free to reopen and provide clear reproducing steps.


Note You need to log in before you can comment on or make changes to this bug.