Bug 1417193 - clicking on warning in the gluster volume tile in the dashboard does not list the volumes where one or more bricks are down.
Summary: clicking on warning in the gluster volume tile in the dashboard does not list...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.1.0.2
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ovirt-4.4.0
: ---
Assignee: Gobinda Das
QA Contact: RamaKasturi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-27 13:24 UTC by RamaKasturi
Modified: 2019-04-22 07:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-22 07:06:38 UTC
oVirt Team: Gluster
rule-engine: ovirt-4.4?
sabose: planning_ack?
sabose: devel_ack?
sabose: testing_ack?


Attachments (Terms of Use)
screenshot for not showing the volumes where one or more bricks are down. (107.86 KB, image/png)
2017-01-27 13:26 UTC, RamaKasturi
no flags Details

Description RamaKasturi 2017-01-27 13:24:37 UTC
Description of problem:
Clicking on warning in the gluster volume tile in the dashboard does not list the volumes where one or more bricks are down.

Version-Release number of selected component (if applicable):
ovirt-engine-4.1.0.2-0.1.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install latest 4.1
2. Create replicate or arbiter volumes
3. Now bring down one or more bricks in the volume by running the command 'kill <pid of brick>'
4. In the dashboard in gluster volume tile you can see that there is a warning with <no.of volumes in warning state(i.e having one or more bricks down in the volume)> with warning symbol comes up.
5. click on the link of warning in the gluster volume info.

Actual results:
It takes you to the volumes tab but does not list the volumes where one or more bricks are down.

Attaching screenshot for the same.

Expected results:
When clicked on warning it should take the user to volumes tab and display list of volumes where one or more bricks are down.

Additional info:

Comment 1 RamaKasturi 2017-01-27 13:26:36 UTC
Created attachment 1245149 [details]
screenshot for not showing the volumes where one or more bricks are down.

Comment 2 Gobinda Das 2019-04-22 07:06:38 UTC
Can't reproduce this, so closing it.


Note You need to log in before you can comment on or make changes to this bug.