Bug 1417195 - Monitor/Jobs + Monitor/Statistics are loading very slow with non-admin user or for users with custom roles
Summary: Monitor/Jobs + Monitor/Statistics are loading very slow with non-admin user o...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Remote Execution
Version: 6.2.6
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-27 13:33 UTC by Marcel Gazdík
Modified: 2019-08-12 14:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-04 18:01:26 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Marcel Gazdík 2017-01-27 13:33:35 UTC
Description of problem:
  Monitor/Jobs + Monitor/Statistics are loading very slow with non-admin user or for users with custom roles. The loading times are at least twice so long compared to admin user and this is the best scenario. 

Version-Release number of selected component (if applicable):
RedHat Satellite 6.2+

How reproducible:
  Create an user with viewer privileges only and try to access Monitor/Jobs page. Depending on the amount of existing jobs in the system the time needed for showing the page will exponentially grow. The reason for this is simple querying database for every single record in order to verify if the user is authorized to see particular job. 

Steps to Reproduce:
1. Create bunch of jobs (no matter in what state they will finish)
2. Create non-admin user - with view privileges only, or better add another user with custom role
3. Check the delay for loading the page Monitor/Jobs

Actual results:
Admin user:
  2017-01-26 08:13:01 [app] [I] Started GET "/job_invocations" for 192.168.81.1 at 2017-01-26 08:13:01 +0000
  ...
  2017-01-26 08:13:01 [app] [I] Completed 200 OK in 53ms (Views: 42.2ms | ActiveRecord: 3.1ms)
  ...
  2017-01-26 08:13:01 [app] [I] Started GET "/job_invocations" for 192.168.81.1 at 2017-01-26 08:13:01 +0000
  ...
  2017-01-26 08:13:01 [app] [I] Completed 200 OK in 48ms (Views: 39.6ms | ActiveRecord: 2.4ms)

Non-admin user:
  2017-01-26 08:12:18 [app] [I] Started GET "/job_invocations" for 192.168.81.1 at 2017-01-26 08:12:18 +0000
  ...
  2017-01-26 08:12:19 [app] [I] Completed 200 OK in 1312ms (Views: 1190.2ms | ActiveRecord: 92.4ms)
  ...
  2017-01-26 08:12:20 [app] [I] Started GET "/job_invocations" for 192.168.81.1 at 2017-01-26 08:12:20 +0000
  ...
  2017-01-26 08:12:20 [app] [I] Completed 200 OK in 956ms (Views: 913.0ms | ActiveRecord: 27.7ms)

Expected results:
 The time required for displaying the page will be the same or nearly the same for all kinds of users in the system.

Comment 2 Bryan Kearney 2018-09-04 18:01:26 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.