Bug 1417199 - xmlrpc_client.pc is missing Requires: xmlrpc xmlrpc_util
Summary: xmlrpc_client.pc is missing Requires: xmlrpc xmlrpc_util
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xmlrpc-c
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Igor Gnatenko
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-27 14:01 UTC by David Kupka
Modified: 2017-02-02 10:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-02 10:45:01 UTC
Type: Bug


Attachments (Terms of Use)
patch fixing the issue (391 bytes, patch)
2017-01-27 14:01 UTC, David Kupka
no flags Details | Diff

Description David Kupka 2017-01-27 14:01:37 UTC
Created attachment 1245156 [details]
patch fixing the issue

Description of problem:
When building binary that depends on xmlrpc_client library pkg-config --libs returns only "-lxmlrpc_client" but then the linking phase fails because xmlrpc_client depends on xmlrpc and xmlrpc_util.

I believe that this is the result of changing libxmlrpc_client.so from GNU ld script to symlink.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
Try to build application that is linking xmlrpc_client.

Actual results:
Linking fails because of missing libratries.

Expected results:
Linking succeeds.

Additional info:
I'm attaching a patch that fixes it for me.

Comment 1 Igor Gnatenko 2017-02-02 10:32:49 UTC
Awaiting for reproducer ;_

Comment 2 David Kupka 2017-02-02 10:45:01 UTC
Closing as this is bug in our build system, thank you for explanation over IRC ;-)


Note You need to log in before you can comment on or make changes to this bug.