Bug 141721 - logwatch for sendmail logs clone statements incorrectly
logwatch for sendmail logs clone statements incorrectly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: logwatch (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-03 03:02 EST by bjorn l.
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-27 11:16:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description bjorn l. 2004-12-03 03:02:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
The sendmail script has the entry:

      ( $ThisLine =~ m/^clone [a-zA-Z0-9]+, owner=/ ) or

But my maillog has entries of the form:
    
      clone: owner=xxxxxx

where xxxxxx is the owner id.  This is verified by looking
at deliver.c in the sendmail source:

                        if (mode != SM_VERIFY && LogLevel > 4)
                                sm_syslog(LOG_INFO, e->e_id,
                                          "%s: clone: owner=%s",
                                          ee->e_id, owner);

The format in logwatch was used in sendmail 8.11.x;  the format
shown above has been used on 8.12.0 and successors (since Sept. 2001)

So I think you need an additional sendmail logwatch entry that
looks something like:

       ( $ThisLine =~ m/clone: owner=/ ) or


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run logwatch (sendmail) on modern sendmail with -owner list, or
2. Look at the code for clone statements
3.
    

Additional info:
Comment 1 bjorn l. 2004-12-03 03:04:30 EST
And on a somewhat related note, the sendmail script header says:
     Please send all comments, suggestions, bug reports,
              etc, to shiva@well.com.

But that is no longer a working address.  So that notation should
be either deleted or changed to a current address.
Comment 2 Ivana Varekova 2005-06-27 11:16:23 EDT
This bug is fixed in the last version (logwatch-6.1.2-1).

Note You need to log in before you can comment on or make changes to this bug.